0

I have created the following site columns inside our root site collection:

enter image description here

and we added some test data inside the related list which have the above site content type and site columns. after 24 hours I checked our Search Schema >> Managed Properties >> I found that 3 managed properties were already created for us repressing these columns internal names (ContactCustomerName = ContactEmail + ContactLastName):

enter image description here

but there is not any crawl property linked to them. Can anyone advice on this weird case please?

1 Answer 1

1

That is just the way it is now with SharePoint online. If you click into one of the automatically created managed properties you'll see a banner at the top that says:

Automatically created managed property. Search automatically created the CONTACTEMAILOWSTEXT managed property, but can't display the actual automatic settings and mappings here. Instead it displays all settings as disabled, and no mappings. If you add a crawled property mapping here, search adds it to the automatic mappings. Learn how you can see which crawled property was automatically mapped to this managed property. If you change a setting here, search overwrites all the automatic settings and mappings with those displayed here.

They work and will have data, but you won't see it in the schema.

4
  • thanks for the reply.. so is there any harm if i manually add/map the related crawl properties? or it is not recommended to touch those automatically created managed properties?
    – John John
    Dec 6, 2021 at 19:06
  • also in my case i can not see any banner at top!
    – John John
    Dec 6, 2021 at 19:08
  • 1
    Strange that you don't get the warning message. Have your tried a query to see if the values are in the automatically created managed properties? I wouldn't recommend remapping them if they are already working.
    – Rothrock
    Dec 6, 2021 at 19:57
  • which query i can use?
    – John John
    Dec 6, 2021 at 20:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.