I am working with SharePoint 2010. I was making some changes to master pages of my site. Then this error started coming

The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable.

Could you please help me on this.

Thanks Vivek


You might have referred an image or style sheet or some file from an invalid path. Check the error in detail, where you might be able to know which file or file path is not correct. Then recorrect it in the master page and then refresh the site.

UPDATE - Can you configure the web.config to display the detailed error? Make - <CustomErrors Mode="Off">, CallStack="true" and <compilation debug="true" />

Do an IISReset and then refresh the site.

  • Well I was just changing the properties of TopNavigation But I have reset the master page. Still id dint help. – V.B Feb 22 '12 at 10:50
  • Now some pages of Central Admin and some of my site collection are accessible like "Site Settings" etc. But not others.I doubt some master page has problem.Any idea how to resolve it? – V.B Feb 22 '12 at 11:17
  • apply v4.master as the custom master page and check if you are able to access the pages. If yes, then scrutinize your custom master page with path errors. If not, please detail the error that you are getting. – Deepu Nair Feb 22 '12 at 11:47
  • I tried to change the master page but still no luck. I checked the logs and the error its logging is about unsafe controls on master page.That the controls on master page are not registered as safe hence the master page is breaking all the pages. – V.B Feb 23 '12 at 5:19
  • Unsafe controls on master page means there are some web parts or user control referred at the top of your custom master page that has not been registered safe in the web.config. This wont usually happen for default master pages. See this link for more info - grounding.co.za/blogs/brett/archive/2008/05/23/… . Remove those entries from the master page or register them as type safe in your web.config. It should work. – Deepu Nair Feb 24 '12 at 4:19

At last I resolved the problem. It was some custom mater applied to central admin not known to me. It had the ascx path problem (~/) was missing. On restoring the path everything is working fine. Thanks all for your help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.