1

I am trying to "uncheck" the "Send an email invitation" checkbox that is ticked by default while you try to grant access to something on SharePoint.

50% of the email addresses, I can "uncheck" this option. But the other 50%, I can't "uncheck" the option.

Does anyone knows why I can "uncheck" for some email address while I can't do the same for other email address? And is there any solution?

enter image description here

2 Answers 2

0

I am seeing the same behavior when I am trying to grant permissions to email addresses which are outside of our organization.

For example:

  • My work email is [email protected]
  • When I am trying to grant permissions to email address like [email protected], I can uncheck the checkbox
  • When I am trying to grant permissions to email address like [email protected] (or any other email outside my organization/tenant (contoso)), I am unable to uncheck the checkbox

Also, there is no out of the box way to customize the permissions sharing dialog in SharePoint online.

3
  • Same for me but I can grant access to around 50% of the email addresses that belongs to outside of my organization.
    – Syahidati
    Nov 17, 2021 at 7:42
  • I am able to grant permissions to all email addresses. It's just I cannot uncheck the checkbox when email address outside of organization is entered. Nov 17, 2021 at 7:47
  • I noticed that this behavior is only for newly added external/guest users. If I am sharing site to external users already added in my Azure AD, I can uncheck the checkbox. Nov 17, 2021 at 10:11
0

Here is a similar thread, as mentioned:

When we first invite the external users to access SharePoint Online site, an invitation is sent to them via email which contains a link to the site, they must use the link to log in and verify their identity. Once they have accessed the site for the first time, these external users are added as guests to our Office 365 directory. In this case, the “Send an email invitation” option is mandatory.

Once they are in the user list in your Office 365 subscription, we can grant them access to other sites or documents without sending them additional invitations. In this case, we can uncheck the “send an email invitation” option when share with external users. Please note we need to wait some time after sharing with external users for the first time, then share other SharePoint sites in the same tenant without emails.

Reference: External sharing overview

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.