1

Problem:


I would like to add a field (called Project Manager) to the properties form, but the edit button is not available as you can see in the picture below, so I draw it.

(I think it should be enabled somewhere but after a long research I didn't found some useful information).

Expected result:


Add Project Manager to the properties form of the list when a new item is added

Resource:


[1]: https://i.sstatic.net/vzBqd.png

What's the best practice function to use to achieve the above result?

Any help will be highly appreciated.

14
  • Are you using multiple content types in your list? Did you make the "Project Manager" field hidden from content type settings? Commented Oct 28, 2021 at 12:37
  • Hey Garesh, thank you for your prompt reply. Actually, I didn't make any modifications to the content type settings because I want to know where I can find it to add this field to display it inside the form library? Could you please provide a screenshot or the steps to add that field on the default Document library form content type? Commented Oct 28, 2021 at 13:45
  • When you create a new column, you see Add to all content types option where you have to select Yes. Commented Oct 28, 2021 at 13:54
  • Please find the link I provided that shows the issue while trying to add the column to the "Folder content type", btw is this the right away doing it or it should be on a different content type? Error Image Looking forward hearing your response and your help is highly appreciated. Commented Oct 28, 2021 at 14:59
  • No, this is not a right place. Is "Project Manager" field new in your document library OR it has some data from documents? If new (so you will not loose any data), you can re-create the column & while re-creating column, select "Yes" to "Add to all content types". Commented Oct 28, 2021 at 15:53

1 Answer 1

1

You can add a column on list/library form by adding column in content type.

If "Project Manager" field is new (so you will not loose any data), you can re-create the column & while re-creating column, select "Yes" to "Add to all content types".

Else if column is already created & there is data in column (added somehow using code or any other way):

  1. Go to library settings >> advanced settings
  2. Set allow management on content types to Yes & save.
  3. On library settings page, select "Document" (content type where you want to add column) from "Content type" section
  4. Select Add column from library/list >> Add project manager column in your content type

Change default content type & order of content types:

You can change the default content type as "Document" & order from library settings page. Follow below steps:

  1. Go to library settings

  2. Under Content types section, select Change new button order and default content type

  3. Set Position from Top for "Document" content type to "1"

  4. Click OK.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.