I have a question regarding a SharePoint Online App installation and using it on a SharePoint Online SiteCollection. The site template is a 'Communication' site.

I used the below articles to install the app.

  1. https://www.sharepointdiary.com/2020/11/add-custom-css-to-sharepoint-online-modern-page.html
  2. https://www.sharepointdiary.com/2019/12/deploy-app-to-app-catalog-in-sharepoint-online.html
  3. https://docs.microsoft.com/en-us/sharepoint/dev/spfx/web-parts/get-started/serve-your-web-part-in-a-sharepoint-page

Please refer the below points.

  1. The App targeted to install 'Modern Script Editor Web Part'. This is also called as 'React Script Editor Web Part'

  2. The app was successfully installed on the Sp Online 'App Catalog' site. Please refer to the screenshot below. AppStore SC

  3. Once uploaded to the App-Catalog site, I saw it in the SharePoint Online site under 'Site Contents'. Please refer to the below screenshot. Site Content SC

  4. However when I tried to add it to a page(a site page), it didn't show up in the 'Web part picker'. Please refer to the below screenshot. Site WebPart Picker Sc

  5. The 'Modern Script Editor Web Part' is activated as a site feature in the 'Site features' of the SharePoint Online site that intend to use it. Site feature SC

I can't understand what I'm missing. I have tried several times. But was not successful. Please can someone help me to solve this issue?


  • Did you enable custom scripts on your tenant? Oct 27, 2021 at 9:04

1 Answer 1


Please enable custom script in SharePoint Online using PowerShell at the site collection level.

#Config Parameters
#Get Credentials to connect
$Cred = Get-Credential
#Connect to SharePoint Online Tenant Admin
Connect-SPOService -URL $AdminSiteURL -Credential $Cred
#sharepoint online enable custom scripts powershell - Disable DenyAddAndCustomizePages Flag
Set-SPOSite $SiteURL -DenyAddAndCustomizePages $False

If you want to enable it at tenant level, please go to SharePoint admin center>Settings>classic settings page>choose the related setting and allow it: enter image description here

  • Hi @Julie_MSFT, I have tried PowerShell commands mentioned above. However unfortunately I got an error after executing Connect-SPOService -URL $AdminSiteURL -Credential $Cred. The error is Connect-SPOService : The sign-in name or password does not match one in the Microsoft account system. At line:1 char:1. I have given the admin account details to the pop-up input box after executing the previous command, $Cred = Get-Credential I have also used the feature from Classic Settings page' allowed **Custom Script. However the app is not enabled in tenant level.
    – ChiranSJ
    Oct 31, 2021 at 19:40
  • I also noticed that, in my root site the app is activated. I also tested it out and it works there perfectly.
    – ChiranSJ
    Oct 31, 2021 at 20:09
  • If you find any reply helpful to you, please remember to mark it as an answer, it will help others who have the same issue.
    – Julie_MSFT
    Nov 1, 2021 at 5:48
  • Hi @Julie_MSFT, Actually, my issue is not fully resolved. That's why I didn't mark a comment as an answer. Could you kindly assist me to solve the issue when I tried to execute the Powershell commands as mentioned in my previous reply? I think I cannot deploy the app at the tenant level. Can you explain what I have done wrong? Regards, Chiranthaka
    – ChiranSJ
    Nov 1, 2021 at 14:42
  • Refer this article to solve the "sign-in name or password does not match one in the Microsoft account system” Error in SharePoint Online: sharepointdiary.com/2020/07/…
    – Julie_MSFT
    Nov 2, 2021 at 2:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.