When running the configuration wizard I got this problem

SharePoint Products Configuration Wizard An error has occurred while validating the configuration settings. An exception of type System.Security.Principal.IdentityNotMappedException was thrown. Additional exception information: Some or all identity references could not be translated.

  1. its a hyperv farm, one server for sharepoint and another one for sql server 2008r2 with active directory.
  2. sharepoint 2010 was installed with sp1 and cumulative updates also, before running the configuration wizard.
  3. The account I am trying to use in the wizard has already permissions on the local administrator group, this account was also added to the sql box as syssecurityadmin and dbcreator

By searching the internet I found this error many times, specially in shaarepoint 2007 not many times in 2010. 1. I tried giving permissions to all roles to the user. Didnt work 2. I tried giving read permission in the active directory. Didnt work.

The servers were prepared by an external team, not the development team, so I am unsure if in their procedure something might have affected that it shows me this exception.

I sent them this URL http://www.mattgrovesblog.com/2009/11/sysprep-windows-2008-r2.html#axzz1n0auCBgG

But I am not sure if that will help the problem.

1 Answer 1


The problem was that the windows server team deployed this virtual server using images that they use all the time, and those images have already some domain policies setup, after running the comand in the blog mentioned above, I could continue with the installation of sharepoint 2010

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.