0

I'm creating my first Microsoft Teams app using SPFx. Here is the tutorial I followed: https://docs.microsoft.com/en-us/microsoftteams/platform/get-started/first-app-spfx?tabs=cli

The app seems to load perfectly on the desktop and browser version of Microsoft Teams, however when I try to open the tab on my mobile device it just has a spinning wheel and never loads.

So in Visual Studio Code Teams Toolkit which allows you to create a "Hello World" Microsoft Teams app template. So I selected the todolist template. And again when I load that custom app on Microsoft Teams, it works on the desktop and browser. But not on mobile. Has the spinning wheels.

So it doesn't look like this issue is code related. It got me thinking. These SPFx custom apps are using SharePoint as a framework, so I'm thinking maybe the reason it's not working on the mobile app is because it's trying to reach SharePoint and not able to do so from my mobile device without some kind of authentication? Is this the case? I have not added any code to this question because I'm not very sure what I should be sending. So I can update this question if someone has any idea on what file or snippet I should send here for review. Thanks

Also this is the SharePoint URL I'm hitting from the Microsoft Teams App: https://NAMEHERE.sharepoint.com/teams/TEAMNAME/Lists/To%20Do%20List

Here is my manifest.json file:

{
    "$schema": "https://developer.microsoft.com/en-us/json-schemas/teams/v1.9/MicrosoftTeams.schema.json",
    "manifestVersion": "1.9",
    "packageName": "todoList",
    "id": "aa57c949-dd58-4dc6-88ad-dcbd8eb4eb6e",
    "version": "1.0.0.0",
    "developer": {
        "name": "SPFx + Teams Dev",
        "websiteUrl": "https://products.office.com/en-us/sharepoint/collaboration",
        "privacyUrl": "https://privacy.microsoft.com/en-us/privacystatement",
        "termsOfUseUrl": "https://www.microsoft.com/en-us/servicesagreement"
    },
    "name": {
        "short": "todoList"
    },
    "description": {
        "short": "todoList",
        "full": "todoList"
    },
    "icons": {
        "outline": "outline.png",
        "color": "color.png"
    },
    "accentColor": "#004578",
    "configurableTabs": [
        {
            "configurationUrl": "https://{teamSiteDomain}{teamSitePath}/_layouts/15/TeamsLogon.aspx?SPFX=true&dest={teamSitePath}/_layouts/15/teamshostedapp.aspx%3Fteams%26componentId=aa57c949-dd58-4dc6-88ad-dcbd8eb4eb6e%26forceLocale={locale}",
            "canUpdateConfiguration": true,
            "scopes": [
                "team"
            ]
        }
    ],
    "permissions": [
        "identity",
        "messageTeamMembers"
    ],
    "validDomains": [
        "*.login.microsoftonline.com",
        "*.sharepoint.com",
        "*.sharepoint-df.com",
        "spoppe-a.akamaihd.net",
        "spoprod-a.akamaihd.net",
        "resourceseng.blob.core.windows.net",
        "msft.spoppe.com"
    ],
    "webApplicationInfo": {
        "resource": "https://{teamSiteDomain}",
        "id": "00000003-0000-0ff1-ce00-000000000000"
    }
}
2
  • Check this & let me know if it works for you. Sep 18 at 8:15
  • @GaneshSanap thank you for the reply. I attached my manifest file. Mine does not have contentURL and my website URL points to Microsoft. Again I never touched any of these.
    – hisusu32
    Sep 20 at 16:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.