I have created a flow that sends an email when a new list item is created, via the mail connector, not the outlook connector.

When the user receives an email there is a message in the bottom of the email, saying "Click here if you would like to unsubscribe from this email..", what in the world is that even for?

Especially if it is in a workflow, the user is getting the email for a reason, so obviously I do not want anyone clicking that.

How can I disable that?

1 Answer 1


As per this thread,

Try adding below code at the end in body (HTML editor/Code View) of send an email action:

<div style="display: none;">

OR if above code is not working for you, try adding this code:

    <style type="text/css">
        .custom-div a,
        .custom-div a:link,
        .custom-div a:active,
        .custom-div a:visited,
        .custom-div a:hover {
            text-decoration: none !important;
            color: white !important;

<div class="custom-div" style="display:none !important; font-size:1 !important; color:white !important;">

Also, you can vote on below ideas submitted by other users so that Microsoft can implement/provide out of the box option in action configuration:

  1. Remove unsubscribe link from mail connector
  2. Option to remove the unsubscribe from email form

Update from comments:

You have to add above HTML code in Code View of send an email action:

enter image description here

  • Let me know if you are not able to access the above link & I will add other answers from the thread here. Commented Sep 18, 2021 at 8:21
  • I tried this, and all it does is send the raw HTML in the email as well as show the unsubscribe form message as well
    – BeerusDev
    Commented Sep 20, 2021 at 12:33
  • You have to add HTML/CSS code in Code View of send an email action. check updated answer above. Commented Sep 20, 2021 at 13:15
  • 1
    The first solution in your answer works <div style="display: none;">, the solution with the CSS included does not work
    – BeerusDev
    Commented Sep 20, 2021 at 13:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.