In Classic Experience, there's an "Edit Page" on settings where I can access and set target audience per specific view of SharePoint List, however, this is not possible on Modern Experience.

Are there any ways where I can restrict those so other group user cannot open specific views?

  • Are you using communication site or team site? Sep 6, 2021 at 5:14

3 Answers 3


Per my knowledge, set target audience to specific view in the SharePoint list modern experience is not available.

  • Yes, but are there any ways where I can restrict access per specific view aside from Target Audience in WebParts? Thank you for your response.
    – jeyemcua
    Sep 6, 2021 at 2:34
  • Sorry for that there are no other options to achieve this. Sep 6, 2021 at 6:32
  • Regardless, thank you so much for your response.
    – jeyemcua
    Sep 7, 2021 at 9:33
  • You're welcome. Sep 7, 2021 at 9:37

Currently there is No way to use target Audience in SharePoint Modern experience List view web part.

If you are using modern team site in SharePoint, try below workaround & see if it works for you (not guaranteed).


  1. Go to your SharePoint list.
  2. Click on Return to classic SharePoint (You can find it below left side navigation - bottom left corner of the page).
  3. Click on Settings (Gear icon) --> Edit page.
  4. Then select the list web part & then Edit Web Part.
  5. In web part properties panel, expand Advanced section, it is on the most right corner of the page next to the list (you may need to scroll horizontally, as shown below).
  6. Inside Target Audiences add your administrators group (admini_folder).
  7. Click OK.
  8. Click on PAGE from top ribbon --> Select Stop Editing.
  9. Click on Exit classic experience (You can find it below left side navigation - bottom left corner of the page).

This only works for groups, so you need to add your user to a group.

enter image description here References:

  1. Check Target web parts to an audience at: How does Audience Targeting in a List / Document Library work?
  2. Check Web Parts topic on Page 4 at: Audience Targeting in SharePoint.
  • But when you convert back , Target audience that you set will not work.
    – Saira
    Sep 6, 2021 at 23:44
  • Yes, I tried your suggestion but not working when reverted to Modern Experience. But thanks anyway for response.
    – jeyemcua
    Sep 7, 2021 at 9:35
  • You're welcome. Unfortunately, audience targeting is not yet supported in modern experience. Above workaround worked for me in the past (1-2 years back), I will check if it works now. Sep 7, 2021 at 10:09

List settings, Advanced settings, Classic experience (last setting on the Advanced page). Believe this forces the classic view and thus the audience targeting. In any case did not see the “Exit classic view” after changing the setting.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.