I am the owner of an SP online site and the permissions tab has been disabled for me. enter image description here

Url of the above page is:


but I can still add users to the documnet library through the right-hand side menu as shown below:

I do not know how this has happened or how to fix the issue.

It seems that I can manage the groups in SP designer 2013 as well enter image description here

Can it be due to ShortPoint SPFx? it seems I cannot remove it as there is no remove button for it: enter image description here

  • Is the URL of the page shown in your screenshot https://<siteurl>/_layouts/15/user.aspx ?
    – Allen_MSFT
    Sep 3, 2021 at 6:04
  • Yes, it is @Allen_MSFT Sep 3, 2021 at 6:47
  • 1
    From the given URL: Tenant.sharepoint.com/sites/SiteName/_layouts/15/…, is it the permission page of a list? And from the screenshot, it seems that you have stopped inheriting permissions in the list, right? Do you have appropriate permission to the lsit? Also change a browser to have a try.
    – Allen_MSFT
    Sep 3, 2021 at 7:05
  • It is the permission of a list, I have also tried Edge and Chrome, it did not work in any of them, everything was fine, but not sure what has happened that caused the tab to be disabled, it has happened today. Yes, I stopped inheriting permission while the tab was working about a month ago, but the tab was working until yesterday. Sep 3, 2021 at 7:09
  • The permissions tab of library document has been also disabled as well Sep 3, 2021 at 7:11

1 Answer 1


Had to reset MasterPages to site definition in SP designer,

enter image description here

and it seems the problem has been solved.

  • It also solved the problem of showing the "remove" button for removing Shortpoint SPFx Sep 3, 2021 at 8:10
  • You can mark your answer if this issue has been resolved. It will be beneficial to others in this forum who meet similar issues to yours. Thanks for your contribution :)
    – Allen_MSFT
    Sep 6, 2021 at 3:11
  • thanks for the reminder, completely forgot to do this Sep 6, 2021 at 3:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.