OK guys, i need your help! My point is: I formatted my dev machine a few days ago, as so i needed to reinstall everything. Logged in as mammoth\marcos.natan, my user account, i installed SQL Server 2008 R2 Express. Next, also logged in as mammoth\marcos.natan i installed Sharepoint Foundation 2010. Ok everything proceeded fine, but when i went to Central Administration i wasn't able to create new web application neither manage service accounts. I launched central administrator with the right mouse button and "Run as administrator". My installation configuration is:

  • Sharepoint setup user account: mammoth\marcos.natan;
  • SQL Server installation account: mammoth\marcos.natan;
  • Farm administrator account: mammoth\marcos.natan;
  • Central administration pool account: NT AUTHORITY\NETWORKSERVICE;
  • Sql server service(Sharepoint) account: NT AUTHORITY\NETWORKSERVICE;

mammoth\marcos.natan is member of the following groups:

  • Local administrators;

NT AUTHORITY\NETWORKSERVICE is member of the following groups:

  • WSS_WPG;
  • SQLServerMSSQLServerADHelperUser$MAMMOTH;

There is something wrong in this configuration? Thanks in advance!

  • What was the problem? What errors did you get?
    – James Love
    Commented Feb 19, 2012 at 22:05
  • In the ribbon, the New button in the Web Applications tab of the Manage Web Applications page is disabled. Also, when i try to add someone to the Farm Administrators group i get a exception that says: "The Local Administrator privilege is necessary to update the Farm Administrators group". Commented Feb 19, 2012 at 22:40

3 Answers 3


Couple of things

  1. Disable Loopback.
  2. Disable IE SEC from Server Admin.
  3. Try adding the http://centraladmin to Trusted Sites / Local Intranet


Could you check the SQL rights for the account that you use to open SharePoint. It should be dbowner and securityadmin or just for the sake of seeing if it fixes your problem make the account a sysadmin on SQL. Also if you have a farm account verify that too has all those permissions.

  • Sorry! I haven't said: My operating system is: Windows 7 x64 Ultimate. Commented Feb 19, 2012 at 23:00
  • How i do this? I need to create a login in the database with a user mapping to mammoth\marcos.natan and give the mentioned roles to the login? How i see the permissions to a user in Sql Server? Commented Feb 20, 2012 at 14:30
  • Hi, you will need to install SQL MGMT studio for SQL Express (if thats the version of SQL that is installed) then you would need to login to your SQL Server. Once logged in , there will be a security TAB. Pull it down and you would be able to view the users that have permission within SQL. By default, SharePoint during installation would enable all the right permissions. This link here wellytonian.com/2010/12/sharepoint2010_installation is my blog post on installing SharePoint has screenshots for SQL. wellytonian.com/2010/10/sharepoint-2010-service-manager - SP2010 on Win 7 Commented Feb 21, 2012 at 15:05

Make sure that the app pool account that you use to run the SharePoint application is the local admin. To ensure, go to IIS manager, check the app pool account or change the app pool account to a local admin account. Restart the IIS and make sure that the Central Admin link is open with "Run as Administrator" option.

  • Thank you Deepu Nair, but this didn't worked! I changed the App Pool account to mammoth\marcos.natan, but i'm still unable to create new web applications or manage service accounts. Make the app pool account member of the local administrators group is not a security threat? Commented Feb 20, 2012 at 14:19
  • mammoth\marcos.nathan if being used to setup SharePoint should have the following previlleages - Local Admin on the box your installing SP and within SQL have dbowner and securityadmin previlleages. Now since this is a sort of standalone box dont worry about the security but see if it fixes your issue. Commented Feb 21, 2012 at 15:07
  • check the services of SharePoint and SQL Server, make all the services to run in a single account (even though its running under network service)- mammoth\marcos.natan. Change all the app pools also to work under this account. Do an IIS Reset and run the CA under admin mode.
    – Deepu Nair
    Commented Feb 21, 2012 at 16:34
  • Thanks AbenSamuel and DeepuNair but, after make the updates, i didn't got success until i disabled UAC on Windows. My configuration now is: SQL Server (Sharepoint) service running under (mammoth\marcos.natan), Central admin app pool, Sharepoint default web app app pool, Security token service app pool and Sharepoint web services root app pool running under (mammoth\marcos.natan). In sql server, i created a new server login mapped to (mammoth\marcos.natan) with the server role sysadmin. I'm facing a lot of dificulties to figure out what is happening. Commented Feb 22, 2012 at 3:15
  • Hii folks! I just can't figure out what is happening. I have a login, named mammoth\marcos.natan, that has the sysadmin server role, on my Sharepoint database instance (SQLExpress\Sharepoint) associated with my windows user, named mammoth\marcos.natan. In the SharePoint_AdminContent_XXXXXXX database, i have a database user, named mammoth\marcos.natan, associated with the login above that is member of the db_owner database role. This should be working isn't? The user, beyond of being part oh the db_owner database role must also be member of the db_securityadmin database role? Commented Feb 25, 2012 at 0:49

Have you tried to logon to windows with the user account mammoth\Administrator and then try to execute your steps in central administration?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.