0

I have followed this link to setup FBA(Form Based Authentication) in my Sharepoint 2016 site. Configured all the necessary web config entries for Membership/Roles/Connection String in 3 Places(Corresponding Web Application,Central Admin Site and Security Token Application).As per requirement,We have given one custom login screen to the FBA Users to signin. Users are able to login using IE11/mozilla browser without any issue but the same is not working with Chrome and Edge Browsers. During Signin, we are checking "Request.IsAuthenticated" property and then redirecting the user to another screen.Validating again "Request.IsAuthenticated" property in the second screen page load, where the response is coming as false always in Chrome and Edge Browsers. Am i missing anything here.?

3 Answers 3

0

Does the site/login page use SSL? Chrome has recently made some changes where the auth cookies aren't saved in certain situations, though I believe a standard setup works if the site uses SSL.

3
  • No SSL. This is in dev environment(Single Server Farm).
    – devsiva
    Commented Aug 6, 2021 at 12:04
  • Then I think this is your issue. You can adjust the chrome security settings so it will work with it, but best is probably to apply an ssl cert to your dev environment. Commented Aug 6, 2021 at 19:59
  • Yes, it works like a charm after applying SSL Certificate in my dev environment. Stuck with this issue on past 3 days. Thanks a lot Chris Coulson. This is working fine now in Chrome and Edge Browsers properly. Thanks for your responses Casey Yang - MSFT and Mandakini Shah as well.
    – devsiva
    Commented Aug 7, 2021 at 7:58
0

Try hitting one WFE server and by passing the load balancer and see if it works. There is similar issue reported here and the fix too. https://docs.microsoft.com/en-us/answers/questions/220620/sharepoint-2013-fba-user-can39t-login-usin-chrome.html

1
  • I am trying this FBA Setup in our dev (single server farm) and there is no load balancer.
    – devsiva
    Commented Aug 6, 2021 at 12:02
0

You could try to use the URL Rewrite module if you do not have a load balancer: https://www.iis.net/downloads/microsoft/url-rewrite

1.Start by selecting the IIS site pertaining to the ADFS/SAML web app 2.Enter into the URL Rewrite module 3.Select Add Rule and then Select the "Blank Rule" under "Outbound Rules", and configure below options (1)Matching Scope: Server Variable; (2)Variable Name: RESPONSE_Set_Cookie; (3)Pattern: (FedAuth=;)(.*)(SameSite=None); (4)Action type: Rewrite; (5)Value: {R:1}{R:2}{R:3};Secure

For Reference: https://techcommunity.microsoft.com/t5/microsoft-sharepoint-blog/effect-on-sharepoint-sites-that-use-adfs-saml-and-forms-based/ba-p/1253873

1
  • Thanks for your response,Casey Yang - MSFT
    – devsiva
    Commented Aug 7, 2021 at 7:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.