2

I set up a modern layout SharePoint web site. But when I edit the left hand navigation I get it only in classic layout. How can I switch it to the modern layout?

enter image description here

5
  • Is it SPO or SP 2019? I have the same experience as yours in my SP 2019 Team site. Aug 3, 2021 at 11:33
  • It is in SPO ...
    – Christoph
    Aug 3, 2021 at 11:36
  • Try the 'Edit' after opening a Site page (modern) Aug 3, 2021 at 11:43
  • unfortunately the same
    – Christoph
    Aug 3, 2021 at 11:47
  • Did you activate any site feature recently on your modern site? Aug 3, 2021 at 13:24

1 Answer 1

0

Left hand Navigation Bar is only available in the Team Site Template, not the Communication Site template.

If you set up a new Site Collection with the Team Site template, the navigation bar should be automatically in the Modern Experience.

If you created just a Site Page in the Modern Experience in an existing Site Collection (that was built with the Classic Exprerience) then you will have to:

  1. navigate to the Site Pages document library, from the Site Contents page,

  2. locate the new Page (built with the Modern Experience),

  3. press the three doted options button and select "Make Homepage" option, in order to set up the Site Collection with the new Site Page as the Homepage (and subsequentally change to the Modern Experience).

Another bug that i had encountered in the past was that i could not use the Modern Features in a Hub Site when i had the SharePoint Server Publishing Infrastucture Feature enabled. It is similar to what you are facing.

If you are not utilising this Feature, go into site settings, then Site Collection Features and deactivate the below feature.

feature to be disabled

4
  • I can see the modern layout in the left hand navigation, but when I am editing the navigation, I only get it in the classic layout and without the user friendly functionalities.
    – Christoph
    Aug 3, 2021 at 11:37
  • Have you set a modern page as the homepage of the site collection?
    – jimas13
    Aug 3, 2021 at 11:38
  • @Christoph i have updated my answer. Could you please check to see if the specific feature is enabled for the site collection and wether you can disable it, in order to try editing the navigational links anew?
    – jimas13
    Aug 3, 2021 at 13:00
  • I ran a test in my dev environment, while waiting and it seems that this feature is what blocks you from using the Modern Experience in editing the navigational links. Please check it in your environment too.
    – jimas13
    Aug 3, 2021 at 13:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.