We are having problems with search application in our environment. The problem is that search works as expected if it's performed from the search center site collection for all sites. But it doesn't work when it's executed from site collection search box and with current site collection scope - results are always empty.

Symptoms as described here are connected to fact, that crawling is being made through other application zone than Default.

Our zones are configured as follows:

  • Default zone on port 443 with ADFS authentication only and published on the Internet
  • Extended web app to Intranet zone on port 1443 with ADFS and NTLM for administrative purposes from inside network.

From above it's obvious we can crawl our content only by Intranet zone (because of NTLM), but since it's not default zone search doesnt work properly for scope other than "all sites".

I'd like to ask you if you could give me some advice and hints on how I could rearange my web application to be able crawl it's content properly (without deleting it entirely ofc ;))


When I search site collection I end up in default search page. It shows no results and I can click All sites there and I'm taken to search center and see results from all sites. Site collection search doesn't work in both zones, and search center searching works in both zones. Rewriting search result links didn't help. What is more, I have to login to do search on my site collection although I have anonymous access enabled. I'll also add that I set site collection to use search center, but I didn't change default results page - /_layouts/OSSSearchResults.aspx

Edit 2:

Changing search configuration on site collection:

  • Disabling custom scopes
  • Changing default results page to search center result page

Gives the same symptoms - there are no results. Parameters k, cs and u are passed correctly (I suppose).

2 Answers 2


Here's a couple of options for you:

  1. In Central Admin, go to your Search Service Application (Content SSA if you use FAST Search for SharePoint) then navigate to Server Name Mappings and create one. Set the "Address in index" field value to your Extended zone url (the one configured to be crawled in the content source) and set the "Address in search results" value to your Default zone url. Submit a new full content crawl and the search results will show up once the crawl is complete.
  2. Flip the zones to make Default zone use NTLM and Extended zone to use ADFS so that you crawl the Default zone.

The reason you get no search results for contextual search queries is the site url filter that SharePoint appends to the query. The site url in your case would be the Default zone url. The site url value that is stored in the search index would be the Extended zone url as that's the zone you crawl your content from.

  • I'll definitely look into your suggestions. Are there any materials showing how to flip zones without harm to web application content (since there are two web apps in IIS)?
    – jjczopek
    Feb 20, 2012 at 21:34
  • 1
    I don't have the specific steps on how to flip the zones but it can be tricky from what I've seen. I'd suggest trying option #1 first. Feb 20, 2012 at 21:40
  • And first option worked perfectly - getting scoped results as expected! Client will be delighted ;)
    – jjczopek
    Feb 21, 2012 at 0:28
  • Thanks Vassili! #1 worked for me. I had extended my webapp and the crawl was successful, built no results. Sep 10, 2014 at 21:02
  • @VassiliAltynikov do you know if option1 is applicable for SP2013 as well? I added both url to my content source, now when i remove short url i stopped getting search results on the site (when accessed through short url) Apr 26, 2017 at 19:33

OK, there's a lot going on here. Let see if I get it.

When you search from a site collection search box (when it doesn't work) do you end up in a search center or the default search page? Is your site collection setup to use the search center? Technically, the search center has one set of web parts for results, regardless of where the request comes from iit will work.if your site collection isn't using a search center, try setting one up.

Regarding the two zones, what zone are you in when you search using the search center (when it works) and what zone are you in when the site collection search doesn't work? There is a setting in search (via central admin) that you can rewrite the search results links. Sorry, I don't have my farm up right now so I can't get you the exact setting. This setting will allow you to index the site using one URL, and return the query results with another URL.

  • I updated my question with feedback regarding your advice.
    – jjczopek
    Feb 19, 2012 at 10:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.