1

I have received a request today to hide/delete a site content type. I thought it is an easy task but it's making me sick.

Every time I try to delete the content type I am getting the below error message.

Is there any way I can hide it instead of deleting it?

enter image description here

2
  • Do you want to hide it from a single list or complete SharePoint site? You can hide content type in a list easily. Jul 19 at 4:24
  • can you let me know both?
    – Harris
    Jul 19 at 5:01
0

This is an expected behavior in SharePoint. If you are using the content type in a list, you cannot delete it directly from site.

First you have to remove the site content type from all lists & then you can delete it from site settings --> Site content types.


Alternatively, you can hide the content type from list instead of deleting it. Follow below steps:

  1. Go to list settings --> Advanced settings

  2. On advanced settings page, set Allow management of content types to Yes & click OK at the bottom of page

  3. Then from list settings page, select Change new button order and default content type under Content Types section.

    enter image description here

  4. Uncheck the content type you want to hide & click OK

    enter image description here

1
  • To top the answer, you need to as well delete the items from recycle bin that were using this content type. Jul 19 at 13:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.