1

SharePoint keeps asking for logon details and there is no "remember me" option. I have tried the different options within the "Internet Options" settings and "Credential Manager" options, but doesn't seem to help. I think this is because this logon screen is not triggered by an .htaccess/.htpasswd ? How can I make my machine auto-login with some preset credentials? What do i need to change on the SharePoint server to make this work?

So I am able to logon and navigate the website, but I want to auto-login with some pre-set credentials. I'm using SharePoint 2013, the website is accessible from the internet.

SharePoint 2013 logon

1

I resolved my issue. Apparently I had to add a "Windows Credential" instead of a "Generic Credential" in the flow described in this article: https://kb.intermedia.net/article/1668

Probably because it authenticates through an Active Directory setup?

Both Chrome and Edge don't show a "remember me" checkbox, but Internet Explorer 11 did. By using Internet Explorer 11 and enabling "remember me" I noticed that "Windows Credential" was added to the list of credentials in my "Credential Manager". Now I can open the website in Chrome and Edge without being prompted for a username/password.

Note that I had to add my site to the trusted sites and enable "Automatic logon with current user name and password".

the windows credential is straightforward: just the domain-name, without the https prefix, just plain: www.mydomain.com. and then your username and password, where my username was similar to my-ad-domain/username.

0

When you using Chrome to access SharePoint, the login credentials box does not have the "Remember me" option.

If you don’t want the browser to keep prompting for authentication, you can disable Loop Back Check.

Please following steps:

1.Open the Registry Editor, locate and then click the following registry key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa

2.Right-click Lsa, point to New, and then click DWORD Value

enter image description here

3.Type DisableLoopbackCheck, and then press ENTER.

4.Right-click DisableLoopbackCheck, and then click Modify.

5.In the Value data box, type 1, and then click OK.

enter image description here

Reference:

2
  • thank you for your reply, but this doesn't address my issue. i will post an answer shortly that solved my problem. Jul 6 at 11:39
  • 1
    Hi, invalidusername. I'm glad to hear that your problem has been solved. You can mark your answer. The behavior will help others who meet the similar issue in the future quickly find the correct answer. Jul 7 at 0:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.