A simple question - How do I remove the white space / blank line from between the text?

Much to my surprise, the options I see when editing the web-part don't allow me to do this. Do I have to use CSS to do this?

picture of a Text web-part on a modern page

  • 1
    Did you use the "Heading 1", "Heading 2", etc. for this or "Normal text" with bigger font-size? Jun 21, 2021 at 12:20
  • I've used Normal text and a bigger font-size. It's a good suggestion to use the Heading options, as they do decrease white space.
    – Tally
    Jun 22, 2021 at 9:42

2 Answers 2


Instead of hitting Enter, hold down Shift and hit Enter. That way, the text is in the same paragraph and the spacing applied before and after a paragraph is not used.

enter image description here

  • That worked perfectly. I didn't really want to switch to the other Heading 1, Heading 2 or Heading 3 options, as they change the way it looks, but this could be an option for others (this was Ganash' suggestion).
    – Tally
    Jun 22, 2021 at 9:41

Each new line in a Text web part uses the <p> tag. And <p> tag has the margin-bottom:1.4em. Due to that, we will get some blank space below the line.

To avoid it,

  • Use the custom CSS
  • Add the Ordered List or Unordered List element
  • Have the content within a single paragraph.

Hope this helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.