0

I'm trying to move a wss 3.0 application to a 2010 foundation server.

What I've done so far:

  1. Restored wss3 content database to SQL Server used by spf2010 server (it's on a separate achine).
  2. Created application with the same name of the one on wss3.
  3. Removed its content database through web administration.
  4. Tried to attach db to my application using these commands:

.

$password = ConvertTo-SecureString 'mypass' -AsPlainText -Force
$credential = New-Object System.Management.Automation.PSCredential ('sqluser', $password)
Mount-spContentDatabase –name DBName –databaseserver SQLServerName -databasecredentials $credential –updateuserexperience –webapplication http://my.intranetapp.com

The last command gives me the following error:

Mount-spContentDatabase : Some Or All Identity References Could Not Be Translated.
At line:1 char:24
+ Mount-spContentDatabase <<<<  -name Intranet -databaseserver rrpc -databasecredentials $credential -updateuserexperience -webapplication Intranet
    + CategoryInfo          : InvalidData: (Microsoft.Share...ContentDatabase:SPCmdletMountContentDatabase) [Mount-SPContentDatabase], IdentityNotMappedException
    + FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletMountContentDatabase

I'm pretty sure that sql server name, credentials and application name are recognized by sharepoint, because if I try to insert wrong values for these parameters I receive an error message accordingly ("can't connect", "wrong credentials", "application not found",...).

I also tried to change db name, but in this case I have the same "some or all identity references ..." error. Of course I'm sure db name is correct.

UPDATE 22/06/2021

I tried to restore and attach my content database on SQL Express on the sharepoint machine, using this:

Mount-spContentDatabase –name DBName –databaseserver MYSRV\Sharepoint –updateuserexperience –webapplication http://my.intranetapp.com

and it's working.

So the issue is definitely with SQL authentication. Unfortunately, I MUST use SQL authentication.

0

Specifying a credential is for when using SQL authentication. Try dropping the credential from your cmd.

3
  • Thank you Trevor, I'm actually using sql authentication.
    – Disti
    Jun 21 at 15:48
  • Any particular reason? It's considered less secure and should be avoided where possible. Jun 21 at 16:00
  • Unfortunately at the moment I need to use SQL authentication. I find it weird that if I try to input wrong user or password, I have an "invalid credentials" message. With the right credentials I receive the "some or all identity references..." error, no matter if I specify the right db name or a non-existing one.
    – Disti
    Jun 21 at 16:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.