0

I have a SharePoint 2016 On-Premise two servers farm, one front-end and one for the search. Everything worked fine until few days ago.
The first has a continuous cpu load of 100% where the IIS Worker Process takes what it finds, the latter works fine. I noticed that the SQL SharePoint instance takes 20gb and a 50% of CPU. I checked the IIS logs (SharePoint) and I found a lot of 401 errors, but the farm works, slow but it works. Event Viewer has no erros regarding to SharePoint or Authorization.

I tried to restart the SQL Server and the SharePoint front-end, for ~5 minutes the CPU is stable at 30%, then it rises to 90-100%. Restarting just the IIS leads to the same behavior.

ULS does not have any error.

If I stop the Workflow Manager Backend service, the CPU load goes to 10%. When I restart it, it returns up to 100%.

How can I find the problem?

1 Answer 1

0

Is it an internet facing deployment? Are the Workflows working correctly? 401, basically means Unauthorized Access Exception. Could it be that the Workflow Manager Backend service has become misconfigured somehow? Have you tried re-installing the Workflow Manager Backend service? You should, also, check that there are no forgotten services with outdated cached password trying to enter the sharepoint API.

Unfortunately, there's not much more that i could think of in order to help.

6
  • Thanks for your answer. As I wrote in the question, the farm is working, slow but working. Reinstalling the WF-Manager requires time and is always a fight, it would be the last of my choices. I think the problem relies between SharePoint->SQL servers.
    – Emaborsa
    Jun 18, 2021 at 12:21
  • Then you should run a report of extended events on the sql server. This will show you want can be happening and which procedures are stalling. I had faced a similar problem when a client of mine had changed the List View Threshold and was trying to view a document library with thousands of items inside. Lifting the upper limit of list view threshold made a huge impact on the SQL Server, since the SQL server was searching for 100.000 items on each run, and, overall, it made the whole installment slow. Switching the list view threshold made the installment operable once again.
    – jimas13
    Jun 18, 2021 at 13:04
  • In the Event Viewer -> Application and Service Logs -> Microsoft-Workflow -> Operational I've seen there are a lot of entries, ~20 per second. I think this is the problem, there must be one or more WF stuck. I wrote a PowerShell script in order to find them...
    – Emaborsa
    Jun 18, 2021 at 14:16
  • Then you will have to map all of the workflows and search for their triggers.
    – jimas13
    Jun 18, 2021 at 15:11
  • 1
    Glad to hear that you resolved the issue! Great Job!
    – jimas13
    Jun 21, 2021 at 8:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.