0

Facing an issue with the Date fields in Modern SharePoint. When I type in the date or select a date and then change the year (by manually editing in the input box), it does not get saved.

It used to work in classic SharePoint and still does on the same site in classic mode but not in modern.

enter image description here

Changed the year in the text input:

enter image description here

It does not get saved. Default date is set to today. Even if you do not set default date, it will save as a blank if I enter/edit the date using the input text box.

enter image description here

Has anyone faced this issue? Is it a known Modern SharePoint issue/limitation?

I searched on the UserVoice if anyone has raised this but couldn't find anything.

Is there any workaround for this (please do not suggest editing the form using PowerApps)?

1

I tried to reproduce this issue on our SharePoint site & observed the same behavior for Date only columns.

However, it is working as expected for Date and Time columns.

I will suggest to create a Support ticket with Microsoft for this issue.


Update:

Manual input in date field is working for me on Standard release tenant. Facing this issue on Targeted release tenants.

1
  • 1
    Yes it works when it is a Date & Time but not when it is a Date only Jun 16 at 8:41
0

---------------------------Update-------------------------------

The result is the same as you when creating a new item, we recommend you get support from Microsoft.

https://docs.microsoft.com/en-us/microsoft-365/business-video/get-help-support?view=o365-worldwide

---------------------------------------------------------------------

I could not reproduce your issue in SharePoint online with Date only column:

enter image description here

Please check if the issue occurs on other lists/libraries/sites.

enter image description here

2
  • I have tried on 2 separate tenants on multiple lists. It does not work for me. Jun 16 at 9:36
  • @Julie_MSFT, you are trying this on Edit/Details form & for me, this issue is happening for New item form. Jun 16 at 10:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.