I don't know what I did but when I click on the Job Definitions link in Central Admin I get a Security Error.

I ran the Configuration Wizard and get this.

02/15/2012 11:20:29  6  ERR                Failed to register SharePoint services.
An exception of type System.Security.SecurityException was thrown.  Additional exception information: Security error.
System.Security.SecurityException: Security error.
   at Microsoft.SharePoint.Administration.SPAutoSerializingObject.GetInstanceFromType(Type type)
   at Microsoft.SharePoint.Administration.SPPersistedObject.GetInstance(XmlNode xml, Guid classId)
   at Microsoft.SharePoint.Administration.SPConfigurationDatabase.GetObject(Guid id, Guid parentId, Guid type, String name, SPObjectStatus status, Byte[] versionBuffer, String xml)
   at Microsoft.SharePoint.Administration.SPConfigurationDatabase.GetObject(SqlDataReader dr)
   at Microsoft.SharePoint.Administration.SPConfigurationDatabase.RefreshCache(Int64 currentVersionOverride, List`1& newObjects, List`1& deletedObjects, Int64& newestObjectVersion)
   at Microsoft.SharePoint.Administration.SPConfigurationDatabase.RefreshCache()
   at Microsoft.SharePoint.Administration.SPConfigurationDatabase.StoreObject(SPPersistedObject obj, Boolean storeClassIfNecessary, Boolean ensure)
   at Microsoft.SharePoint.Administration.SPConfigurationDatabase.PutObject(SPPersistedObject obj, Boolean ensure)
   at Microsoft.SharePoint.Administration.SPPersistedObject.Update()
   at Microsoft.SharePoint.Administration.SPServiceInstance.Update()
   at Microsoft.SharePoint.Search.Administration.SPSearchServiceInstance.Update()
   at Microsoft.SharePoint.Search.Administration.SPSearchServiceInstance.Provision()
   at Microsoft.SharePoint.PostSetupConfiguration.ServicesTask.InstallServiceInstanceInConfigDB(Boolean provisionTheServiceInstanceToo, String serviceInstanceRegistryKeyName, Object sharepointServiceObject)
   at Microsoft.SharePoint.PostSetupConfiguration.ServicesTask.InstallServiceInstances(Boolean provisionTheServiceInstancesToo, String serviceRegistryKeyName, Object sharepointServiceObject)
   at Microsoft.SharePoint.PostSetupConfiguration.ServicesTask.InstallServices(Boolean provisionTheServicesToo)
   at Microsoft.SharePoint.PostSetupConfiguration.ServicesTask.Run()
   at Microsoft.SharePoint.PostSetupConfiguration.TaskThread.ExecuteTask()

The Zone of the assembly that failed was: MyComputer

I look in the Log file and see this

Exception in RefreshCache. Exception message :Security error.
02/15/2012 11:09:18.40 OWSTIMER.EXE (0x0360) 0x0570 Windows SharePoint Services Timer 5utx Unexpected The timer service could not initialize its configuration, please check the configuration database. Will retry later.

Please help

  • Is this a new installation of SharePoint or an existing one that just started failing?
    – Dave Wise
    Feb 15 '12 at 16:57
  • This is an existing one Feb 15 '12 at 17:27

You might want to verify that the account that the Timer job (OWSTIMER.EXE) is running as has not expired or been disabled

  • It is running under the NETWORK SERVICE account and the WSS Timer Service is running Feb 15 '12 at 17:47
  • Is the config database on the local machine?
    – Dave Wise
    Feb 15 '12 at 18:19
  • yes.It is using the Windows Internal Database (SSEE) Feb 15 '12 at 19:30
  • When you ran the Config Wizard, were you running it under your own account or the farm service account?
    – Dave Wise
    Feb 15 '12 at 20:09
  • My own account. I am an admin on the server Feb 15 '12 at 21:00

Fixed! Found this blog post mariuszgorzoch.wordpress.com/2010/05/12/… Went into SP DB and searched for timer job I created & tried to uninstall and deleted the records in the object table. Now job definition page comes up again

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.