0

Desired Behaviour

  • Filter items in a Document Library by Column title
  • Click Select All icon
  • ALL items that match the filter are selected (not just those displayed on the user's screen)

The desired functionality is demonstrated in GMail when performing a search and clicking Select All, ie:

enter image description here

Actual Behaviour

It seems document libraries use 'lazy load' functionality where only enough items are retrieved to fill the user's screen.

For example, if I were to apply the following filter on a Column title:

Vehicle Type:  Boat

It might display 100 items.

If I then clicked Select All, the interface would say 100 selected, even though there could be 5,000 results, eg:

enter image description here

enter image description here

Workaround

Currently I am instructing users to:

Keep scrolling until items don't load anymore to ensure all matching documents in the library are loaded and selected

But this is not a scalable or sophisticated solution.

Question

Is there a way to select ALL matching results of a filter in a document library, rather than just those displayed on the user's screen?

Environment

Browser: Chrome Version 91.0.4472.101 (Official Build) (64-bit)
SharePoint Online
Microsoft Team SharePoint Site Document Library

0

I have noticed this in my own environment. The way to get the behavior you desire is to do these two things:

  1. Ensure that the column(s) being filtered on are indexed columns
  2. To index a column got to Library Settings --> Columns section see Image 1 below
  3. Here is the magic: go into the view's edit screen and explicitly set the view's Item Limit parameter to a high number and ensure that "Display items in batches of the specified size" option is selected. See Image 2 below.
Image 1 Image 2
Creating an Indexed Column Item Limit parameter
Result
Result

Interesting fact, even though the default item limit for a new view is set to 30 and the "Display items in batches of the specified size" are the default values, the Modern Experience overrides the batch size to 100.

Hope this helped

Mark as answer if this solved your issue. Upvote if it helped you

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.