0

For some reason, on this content-type which has the value of "SL Document" set as their parent in my content hub, it shows up like this in my Document Library content-type settings:

Content-type with wrong parent

If I then click on that parent link, it reloads into a page called "Site Content Types : Site Content-Type ", and the correct parent content-type of SL Document is listed.

Throughout all of this, my parent content-type's metadata column of "Classification" is missing in the document library. I have republished the parent a few times now, waited a day, and the "Classification" column is not coming through. In the screenshot, you can see that the column from the parent called "Keywords" (multi line type) is coming through. I am out of ideas here, and Microsoft Support has been looking into this for weeks now without any progress. All help is appreciated!

0

We recommend that you perform the following troubleshootings:

1.Add a new site column in the parent content type(Site Content Type), please make sure whether to check the "Update all content types inheriting from this type" option.

enter image description here

2.If it still does not display, please go to the Document library and delete the content type, and then add it again.

enter image description here

3.If it still doesn’t work, I suggest you delete the parent content type(Site Content Type) and recreate it.

enter image description here

3
  • Thank you for your reply. I tried step 1 and 2, and the new test column from the parent, AND my problem column from the parent, did not show up on the content-type before and after removing and re-adding it Unfortunately, I will not be able to delete the parent content type. It is being used on live sites already. – Mysticode Jun 7 at 23:52
  • Hi Mysticode. This is indeed a very unusual phenomenon. I suggest you create a new site content type to see if similar problem occur. – EchoDu_MSFT Jun 9 at 10:28
  • I am working with Microsoft SharePoint engineers on this issue. – Mysticode Jun 16 at 21:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.