16

I am trying to retrive all items that are under a certin folder, in a document library.

this is what i have so far

List DocumentsList = clientContext.Web.Lists.GetByTitle(list);
CamlQuery camlQuery = new CamlQuery();
camlQuery = new CamlQuery();
camlQuery.ViewXml = @"<View Scope='Recursive'>
                        <Query>
                            <Where>
                                <eq>
                                    <FieldRef Name='FileDirRef'/>
                                    <Value Type='Text'>
                                        /ecm/Business/Business/Projects/IDECO_P01030000
                                    </Value>
                                </eq>
                            </Where>
                        </Query>
                        <RowLimit Paged='TRUE'> 30 </RowLimit>
                    </View>";
ListItemCollection listItems = DocumentsList.GetItems(camlQuery);
clientContext.Load(listItems);
clientContext.ExecuteQuery();

it is definately a caml query problem i am just unsure of how to fix it as yet any ideas would be helpfull

  • There was also bad casing for Eq operator. Being an XML dialect, CAML is case-sensitive. – Alexey Krasheninnikov Apr 23 at 10:50
28

i managed to get it working .

i changed the scope from "Recursive" to "RecursiveAll", RecursiveAll gets all files and all folders under the specidified location.

Caml query was replaced with

    camlQuery.ViewXml = "<View Scope=\"RecursiveAll\"> " +
                    "<Query>" +
                    "<Where>" +
                                "<Eq>" +
                                    "<FieldRef Name=\"FileDirRef\" />" +
                                    "<Value Type=\"Text\">/ecm/Business/Business/Projects/IDECO_P01030000</Value>" +
                                 "</Eq>" +
                    "</Where>" +
                    "</Query>" +
                    "</View>";
  • 4
    Sebastien, Your code worked not because you changed the string. It is because you changed the scope from "Recursive" to "RecursiveAll" As RecursiveAll gets all files and all folders under the specidified location. – user13753 Dec 21 '12 at 7:40
  • 1
    hahah, so i see i asked this question when i was till very new to SharePoint :), thanks for pointing that out – Sebastien Stettler Dec 24 '12 at 8:00
  • @SebastienStettler : Hey If i want to check multiple conditions by putting <And> in this query how can i achieve that... – Rahul Gokani May 28 '13 at 4:46
  • 2
    @RahulGokani if you have questions about a specific answer, please use our chat, not comments. Thanx! – Anders Rask Aug 26 '13 at 12:41
  • this is worked ... <View Scope=\"RecursiveAll\"> .. in last two days i want to retrieve all task items in nested folders in task list and search google : summary task nested folders and so on... ( csom clientcontext ) – saber tabatabaee yazdi Feb 17 '14 at 18:54
6

Try setting the FolderServerRelativeUrl property of the CamlQuery. See: here

3

you should also try to load all the folders and files. means

 clientContext.Load(DocumentList);
 clientContext.Load(DocumentList.RootFolder);
 clientContext.Load(DocumentList.RootFolder.Folders);
 clientContext.Load(DocumentList.RootFolder.Files); 
 clientContext.Load(listItems);
 clientContext.ExecuteQuery();

than you can get FolderCollection in Library

 FolderCollection FC = Document.RootFolder.Folders
 Foreach(Folder Fl in FC)
         {
                FileCollection flc = fl.files;
         } 

Hops its help.

2

To get items from specific folder without receursive add to query this options:

<QueryOptions>
 <Folder>thelist/thefolder</Folder>
</QueryOptions>

Note to replace thelist/thefolder with actual relative url

1

Have you tried using comparison operator as 'Contains'

    <Contains>
    <FieldRef Name='FileDirRef'/> 
    <Value Type='Text'> 
        /ecm/Business/Business/Projects/IDECO_P01030000 
    </Value> 
    </Contains>
  • Contains operator is more resource intensive for SQL than Eq or In because the query engine cannot use an index. – Alexey Krasheninnikov Aug 4 '15 at 14:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.