1

I have a SharePoint list where a column contains numbers but those numbers are shown as:

Example: "1,181,180" instead of "1181180" (this is what I need).

I created the list importing from excel.

How can I format this column so I can see it without decimal places and 1000 separator as "." using JSON?

1 Answer 1

0

If you are using Number data type, you can remove thousand operator from column settings:

  1. Go to SharePoint list
  2. Click on column header/name
  3. Select Column settings
  4. Select Edit

enter image description here

It will open column settings panel in modern experience like below. If you don't see the Use thousands separator on panel. click on More options.

enter image description here

To remove thousands operator using JSON, use below JSON:

{
  "$schema": "https://developer.microsoft.com/json-schemas/sp/v2/column-formatting.schema.json",
  "elmType": "div",
  "txtContent": "@currentField"
}

Output:

enter image description here

3
  • I don't see the same as you do. Please check following image: (how can I add an image in a comment?)
    – JosePerezG
    May 31, 2021 at 20:04
  • You are seeing the old/classic experience column settings. In my answer, I am showing you the modern experience way. Jun 1, 2021 at 3:32
  • Check updated answer to see the modern experience column settings. Jun 1, 2021 at 17:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.