1

I can not figure this one out.

How do I remove this menu?

enter image description here

1

The above answer will hide it on that whole site. If you just want to hide the left nav bar on the single list page do the following:

1: Click settings and "Edit Page"

2: Add new web part to the page

3: Choose the script editor web part:

4: Insert the following into the script editor

<script>
<style>
#sideNavBox { DISPLAY: none }
</style>
</script>

Click the gear icon in the top right: enter image description here

Then click edit page and this will appear on the list: enter image description here

3
  • There is no Edit Page option on default list page. Also, OP is using modern experience where you cannot add script editor web part. May 26 at 15:10
  • I just realized it is a modern experience, but you are able to edit and add a web part to the classic experience, see my edited answer.
    – BeerusDev
    May 26 at 15:28
  • I don't think OP will want to move to classic experience, just for hiding the left navigation. OP will loose all the modern capabilities, SharePoint app bar, rich UI, etc. Also, Script editor web part is not available by default. Administrator need to enable the custom script first to use it. May 26 at 16:01
1

Couple of things you can try:

Disable Quick Launch:

  1. Go to site settings
  2. Select Navigation Elements
  3. Uncheck Enable Quick Launch
  4. Click OK

enter image description here

Remove all navigation links:

  1. Click on Edit at the bottom of left navigation
  2. Remove all links one by one
  3. Click Save

Output:

enter image description here


Note: It will hide left navigation from all places & not just lists.

If you want to hide the left navigation temporarily when you are viewing list items/data, you can use the Expand content option at the top:

enter image description here

It will hide SharePoint app bar, left navigation, site title & logo temporarily until you again Collapse content using the same option.


Update from comments:

The quick launch (left navigation) is hidden on lists as well for me:

enter image description here

8
  • Hi @Fredrik, Did you try this? Is it working for you? May 27 at 6:02
  • Hi and thanks for your answer! I have tried these. The settings for Enable Quick Launch is off and I have no links in the menu, the settings where like this already. This left menu is visible on all lists for this site but hidden on all pages. May 27 at 6:06
  • It is working for me in lists as well (check screenshot in updated answer). Did you activate any publishing feature or something on your site? May 27 at 6:15
  • Yes, that sounds familiar! I that do be able to share the top menu across subsites, got that working. I also did that to be able to move pages from one subsite to another if I remember correct, did not get working though. May 27 at 6:17
  • If you don't need the site feature anymore, can you please try the above steps after deactivating the site feature? May 27 at 6:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.