0

I would like to make the fields not editable in all forms. My issue is that when I click on a document, I can edit and save properties.

I'm trying to modify a Library form created with Power Apps.

For this I created a copy of my FormScreen and its form. I have then :

  1. FormScreen_Edit with the following form SharePointForm_Edit
  2. FormScreen_View with the following form SharePointForm_View

enter image description here

Display model for SharePoint_Edit is Modify and display model for Sharepoint_View is display

I also modified the SharePointIntegration part.

enter image description here

2
  • You don't want to allow users to modify the "Name" (Nom) of documents? May 26, 2021 at 13:54
  • it's very weird but i'm asked to do this...
    – davidvera
    May 26, 2021 at 14:07

1 Answer 1

1

Follow below steps:

  1. Go to SharePoint library

  2. Select one document

  3. Click on Properties from command bar at the top

  4. Click on Edit columns dropdown & select Customize with Power Apps.

  5. It will load the properties form in Power Apps (It may take some time)

  6. In Power Apps studio, from tree view at the left click on SharePointForm1 control

  7. Set DefaultMode property to View

  8. Click on File --> Save --> Publish to SharePoint

enter image description here

Output: Non-editable properties form

enter image description here


Even if you don't allow users to edit the properties from form, user can still edit properties from Edit in grid view or Details pane.

To avoid that, you can disable this functionalities by following this steps:

  1. Go to SharePoint library
  2. Click on Settings (gear icon) at the top
  3. Select Library settings
  4. Click on Advanced settings
  5. On Advanced settings page, select No for Quick property editing
  6. Scroll at the bottom of page & click OK

enter image description here

2
  • 1
    thanks Ganesh ! it helped me a lot. In fact it solved the issue.
    – davidvera
    May 26, 2021 at 14:30
  • 1
    you write faster than i upvote and accept as an answer :))
    – davidvera
    May 26, 2021 at 14:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.