0

I have managed to get an auto incrementing column. See below. So the Ref column is incrementing based on how many items there are already in 'Type'. In effect there could be multiple number 1s, but they are unique based on having 'Type' appended to it.

I have the one dimensional increments working based on 'Id' and using O365 Flows in SharePoint.

Any guidance would be much appreciated.

enter image description here

1 Answer 1

0

Please following steps:

1.Create new list named "Auto Increment" and add some columns in the list.

enter image description here

2.Click Integrate >> Power Automate >> Create a flow

enter image description here

3.Create the MS Flow

a.Add "When an item is created" trigger

b.Add "Get item" action

c.Add "Get items" action:

  • Filter Query: Types eq 'Types Value'

d.Add "Compose" action:

  • Inputs: length(body('Get_items')?['value'])

e.Add "Condition" action:

  • Ref is equal to null

f.On the "If yes" branch, add "Update item" action:

  • Ref: R_Outputs_Types Value

enter image description here

4.Save and Test this MS Flow

enter image description here

======================== Updated Answer ========================

Please follwoing steps:

1.Go to the specific list >> List settings >> scroll to Columns sections >> click on the specific column

2.On the Edit Column page, check this column's dispalyname.

enter image description here

8
  • Seems very logical - thank you @EchoDu_MSFT. I get an error on 'Get Items'. The error is that "Column 'Type' does not exist. It may have been deleted by another user." The column is very much present on the list. Any help much appreciated.
    – R D W
    Commented May 26, 2021 at 13:31
  • Hi, RDW. Thanks for your reply. I have updated answer under initial My Answer. Hope this can help you to solve issue. Have a nice day! Commented May 27, 2021 at 1:09
  • Wow- excellent catch. Thank you. Flow now works, however it does not increment. Every item has the same number, which is the latest one. Any thoughts? Thank you!!
    – R D W
    Commented May 27, 2021 at 8:24
  • Also I have noticed that in the final Step, I get the 'Type' Field, but cannot add Dynamic content, it only offers the drop down. Maybe a clue to something I am missing.
    – R D W
    Commented May 27, 2021 at 8:32
  • Output is as per below. I am guessing that it works, unless I add several at the same time? As in, the workflow processes them all at once and therefore adds same reference? Ref Type R1_Car Car R_1_Bus Bus R_1_Bike Bike R_1_Bus Bus R_2_Bike Bike R_2_Bus Bus R_5_Bus Bus R_5_Bus Bus R_5_Bus Bus R_4_Bike Bike R_4_Bike Bike
    – R D W
    Commented May 27, 2021 at 9:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.