0

My client experience the following on their SharePoint Document center on SharePoint 2016 (on premise):

When they save the properties of the files (it does not happen with all files) they get the error message, 'The file xxxx has been modified by xxxx on day and time.

But the person that is setting the properties, is the same user that is displayed in the error message. What can cause this problem?

error message

1
  • Is there any workflow running on the document library? May 19 at 8:04
1

Do you have a workflow associated with Document Set?

If true, please uncheck "Automatically update the workflow stat to current stage name" in SharePoint designer:

enter image description here

Similar issue:

"The file has been modified by..." error, when the workflow starts automatically

6
  • Thank you Julie - I did that allready a while ago, but the problem still persist
    – Heste
    May 19 at 8:56
  • What's the trigger of you workflow?Try as following:"Start workflow automatically when an item is changed" and unchecked "Start workflow automatically when an item is created"
    – Julie_MSFT
    May 20 at 8:38
  • Software sends the document to the library through a certain user called, SoftwareUser. The wf starts when an item is created and checks to see if it was created by SoftwareUser, if true, it will check that all properties are set and checks it in, if false, it will end the workflow. If the document is created by userA for example, the workflow will not check in and stop, because the userA uploads the document manually, sets the properties and checks it in. And it is with the 'set the properties' window, that gives the above message. The workflow should not run when an item has changed
    – Heste
    May 21 at 6:38
  • Please check whether all users except SoftwareUser have the same issue.
    – Julie_MSFT
    May 25 at 8:55
  • Some users have this error occasionally. Not everyone and every time. It happens sporadically.
    – Heste
    May 26 at 11:22
0

I think I found the problem. When a user manually uploads the file and immediately sets the properties the workflow also starts in the same time. That causes a clash between the two processes (saving from user and checking file from wf) I advised my client to ensure the workflow completes before they set the properties. It seems as if that solved the issue. Thank you for everyone's input. It guided me to the solution and I learned a few new tips

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.