1

I have a list column with a date field that I hide when a new item is created.

=if([$Status]=='Pending', 'false', 'true')

The date field is set to default value i.e. "today's date".

When I create a new item, the date field is hidden but when I save it, it writes the wrong time.

The time is always the full hour next (ex. if time is 9:23 it shows 10 ecc.)

Without hiding the formula (i.e. date field is visible while creating a new item), the time is displaying correct.

What is wrong?

1
  • Would you like to share more information about your list? How do you hide the date field? What does the formula mean? Screenshots will be helpful.
    – Jerry_MSFT
    Commented May 14, 2021 at 8:30

2 Answers 2

0

I made test to hide a date and time column in the new form. Set the date and time column default value with Today's Date. Edit the column in the new form to make the date filed not displaying. Still it returns the current time exactly as it is. It works pretty fine in my end. I will suggest you to double check the column settings and share us with the information.

enter image description here enter image description here

0

I tried this on my SharePoint tenant & I can reproduce this issue.

Below are my test results, where both dates have default value set to "Today's date":

enter image description here

I will suggest you to see if your regional settings are different than regional settings of SharePoint site.

For more information, check below documentations:

  1. Change your personal language and region settings
  2. Change regional settings for a site

If that does not solve your issue, Contact Office Support or Get support.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.