I am unable to setup SPFx Development Environment for my SharePoint Online. I installed 10.24 and 10.20 version of Nodejs then also installed gulp and yeoman. But when I execute yo @microsoft/sharepoint command, the nodejs command prompt throws error as shown in below picture. I tried multiple times to uninstall and reinstall 10.x versions of nodejs but the error is same. I am not able to find any information about this error on google.

TypeError: lookup.flatMap is not a function

enter image description here

  • Hi Zakir, Can you please run the following command "npm list -g --depth=0" and post screen shot here. Apr 25, 2021 at 9:52

2 Answers 2


This is the issue related to yeoman. You can fix this issue by downgrading it from 4.0.0 to 3.1.1

npm install [email protected] -g

This combination does not work

This combination works

Similar question was asked here.

  • 1
    Thanks a ton Denis. Your solution worked perfectly. The issue was related to yeoman version.
    – Zakir HC
    Apr 25, 2021 at 14:29

I am assuming that you have installed only one version of nodejs at a time. For SPFx generator SharePoint online you will require v10.24.0 of nodejs.

Open command prompt and run following command in CMD to check global version of package

npm list -g --depth=0

Ideally it should display following following version

+-- @microsoft/[email protected]

+-- [email protected]

+-- [email protected]

-- [email protected]

If you have multiple version of nodejs without using nvm then it will not work.

For more details you can refer the this Microsoft docs.

Set up your SharePoint Framework development environment

  • Yes @Rajat Sahani, one can only install one version of npm at a time. I had installed 10.20 and 10.24 nodejs version at one time. I have npm installed and its upto the lastest version.
    – Zakir HC
    Apr 25, 2021 at 11:53
  • have you unistall old one before intalling new one? Apr 25, 2021 at 11:59
  • Yes I did that.
    – Zakir HC
    Apr 25, 2021 at 12:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.