I am using SharePoint Designer 2013, when I try to add an external system in the external content type dialog, it adds the system, I can browse databases and routines. If I try to browse views then the designer crashes.

I am using SharePoint 2019, SQL server 2017, and as stated Designer 2013.

I have had external systems pointed to the SQL server before successfully, and I can now point to an SQL server 2014 box and successfully create a new external system, just cannot do it to this 2017 server, and only fails for views.

Further previously when creating an external system they were added to BCS with the name used in designer....eg. Add "Production 2017 - Database Name" showed up in BCS the same. Now "Production 2017 - Database Name" shows up in designer as "Production 2017 - Database Name" but in BCS it is named: "SharePointDesigner-Production 2017 - Database Name-65acbe56-708e-4def-ba8a-37b17f5b217e".

Update: Installed new Win 7 box clean with Designer 2013 in case it was being caused by running Designer on Win 10. Same results, Designer crashes when I try to browse views on the database, but can successfully browse tables and routines. Could something be corrupted in BCS? I have used this database for a while with other external types pointing to views in this database. The old external system is now deleted and all external types pointed back to SQL Server 2014 until I fix this. Wonder if something is stuck from deleting the old definition of this external system?????

  • 1
    Views which you are trying to browse is modern view or classic view? Apr 10, 2021 at 12:24
  • It is modern site. This worked fine for years. BCS was migrated from 2010, but worked fine. I have since deleted some of the old external system definition, recreated new ones and pointed content types to new external systems. This was done after it broke, but wondering if something could be stuck in BCS.
    – Chuck
    Apr 10, 2021 at 16:02
  • To clarify, I am trying to create a new external content type in designer. When I add the external system is where I am browsing. I can add the DB and open Tables and Routines in the external system, when I try to open views in the external system, SharePoint Designer 2013 crashes.
    – Chuck
    Apr 10, 2021 at 16:10
  • Modern site view will never open in SharePoint designer, Hope this help. Apr 11, 2021 at 3:27
  • It must be classic then, how can I validate? The site opens in designer, I can create new external systems to my SQL server 2014.......I repointed all external content types to new a external system on a SQL server 2014 so BCS and designer are working fine. It is just my SQL server 2017 which used to work fine. I can create new external system pointing to SQL server 2017 and can add operations to tables or routines(stored procedures). I just cannot add views.
    – Chuck
    Apr 11, 2021 at 10:35


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.