1

I have created a search service application few days back, but when I started crawl getting an error

Could not connect to the search administration web service on server 'Server Name' because the web server is not running.

When I googled it I found it was because of SP Host Controller is disabled, I started the services and set the start-up type to automatic with Logon account domain\SPFarm same for search application. But don't know why the service is getting stopped and disabled, due to the same search crawl and search both is impacting. Please suggest.

1 Answer 1

1

Whether a password update on the service account?

Go to central administration -> Check the service account running the Search Host Controller Service. And make sure the Search Host Controller Service is started in the "Manage services on server".

Go to Services -> SharePoint Search Host Controller Service -> Properties -> Log On tab -> Make sure the account and password.

Update:

In the "Manage services on server", click start. enter image description here

3
  • As you suggested, Search Host Controller Service is stopped, but when I saw jn windows Services it is running (SharePoint Search host Controller services,hope both are same). Please suggest where I can get the properties of Search Host Controller Service, as I can see it is not a link or selectable under "Services on Server" Apr 12, 2021 at 11:29
  • I have updated the answer. Apr 14, 2021 at 10:04
  • Would I need to start the SHC service in both WFE servers, as now service is running on primary WFE but most of the services in secondary WFE are off.. Jun 1, 2021 at 6:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.