0

We have migrated 3 custom lists from SP 2013 to classic team site inside SP online, now the 3 lists have the following main settings:-

  1. we have customized the list forms (Create & Edit) using Script Editor web parts, as follow:-

enter image description here

  1. for the list settings >> we define to render based on the site settings (which is to use modern UI):-

enter image description here

so now the expected behaviour is that the list views will render using the modern UI + But when we create/edit the list items the Create & Edit forms will render using the classic experience. Now this is working as expected for 2 lists. but is failing for the third list.. where on the third list the Create & Edit forms will render using the modern UI, although they have customized the forms using script editor web parts.. any advice on this?

1

This article lists all features that will automatically switch to the classic experience.

Need to pay attention to this:

Only the first customization listed above will trigger a fallback to classic mode on the form.

enter image description here

3
  • but is this a new feature, as things was not working in this way
    – john Gu
    Apr 2 at 12:45
  • What did you mean "this is a new feature and not working"?Please remember to update the List ContentType.EditForm property.
    – Julie_MSFT
    Apr 5 at 8:18
  • what i mean is that previously if we add a script editor web part to the add/edit list forms , then this will force the list forms to render in classic mode, and we did not need to manually define the ContentType.EditForm property
    – john Gu
    Apr 5 at 15:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.