0

My 2016 SharePoint farm, among other servers/services, runs two Front Ends and has Business Data Connectivity setup. I have created an external data source to a SQL server database and an External Content Type via SharePoint Designer. With that, I have created an External List on a site. The two front ends are load balanced.

On one FrontEnd, I can access the external list data by navigating to it in the browser. However, when I am load-balanced to the other Front End, I get the error "A connection was successfully established with the server, but then an error occurred during the login process." with a further message in the ULS logs saying "The certificate chain was issued by an authority that is not trusted". I have compared the certificates, trusted and otherwise on both front ends and the SQL servers. Everything appears in order. I have ensured both front end's bindings are correct to the appropriate sites.

I can't seem to figure out why when load-balanced to one front end it works, but refuses to work on the other. I'm wondering if there is some web.config item that is off or if there is a registry setting messed up somewhere. Has anyone see this or had experience with this in general?

4
  • 1
    Try enabling the CAPI2 log in the Event Log to see what the error with the cert is.
    – user6024
    Commented Mar 28, 2021 at 23:48
  • SSL self-signed fallback provided by the SQL server that I'm querying the external data from. The front end that works returns nothing from that server. Commented Mar 29, 2021 at 3:46
  • 1
    Did you enable the CAPI2 log to get more information?
    – user6024
    Commented Mar 29, 2021 at 15:05
  • @TrevorSeward Yes, what I wrote was what I was seeing in the CAPI2 log. The front end that doesn't work receives an error with Event ID 30. The certificate referenced in the error is a self-signed certificate direct from the SQL server I am pulling external data from. Nothing like that shows up on the front end that does work. Commented Mar 30, 2021 at 1:37

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.