0

When SharePoint (2013) trying to reach APP on the PHA server it goes to AppRedirect.aspx and shows a request like:

https://<SITE_URL>/_layouts/15/AppRedirect.aspx?client_id=<CLIENT_ID>&redirect_uri=http://<PHA_URL>//DocumentSet/Create?{StandardTokens}&SPHasRedirectedToSharePoint=1

But we've got a security warning cause HTTP in this request (redirect_uri=http://). How to change it and where?

What I have done:

  • checked app config via Get-SPAppInstance and it shows 'https://' under 'LaunchUrl'
  • checked AppManifest.xml and it's 'https://' under tag
  • updated the lates version of app
  • on AppRegNew.aspx page when app was registered inside 'Redirect URI' you can put only 'https://'...

Thank you.

0
0

As a workaround I've added this rule on all WFE servers:

<rewrite>
        <rules>
            <rule name="rewrite" enabled="true" stopProcessing="true">
                <match url="^_layouts/15/AppRedirect.aspx$" />
                <action type="Rewrite" url="/_layouts/15/AppRedirect.aspx?{C:1}redirect_uri=https{C:2}" appendQueryString="false" />
                <conditions>
                    <add input="{QUERY_STRING}" pattern="(.*)redirect_uri=http(.*)" />
                </conditions>
            </rule>
        </rules>
</rewrite>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.