0

Here's an interesting one, I'm reviewing an issue where the site owners (of a sub-site) cannot access the 'site permissions' page (/_layouts/15/user.aspx). When they try they get a access denied message.

I'm unsure of the history of the site and how this occurred. I have noticed that the groups visible in this sub-site might have been created manually (after he site was provisioned).

In the top level, where it says 'users with limited access', it displays a list of groups of other subsites. There is no group listed for the site with the issue. How can this be rectified? As the sub-site has an owner group, associated with lists/libaries, I did not want to create a new group and re-associate with these lists/libaries :)

Thanks

2
  • Are Site collection administrators able to access site permissions? – Ganesh Sanap Mar 11 at 17:32
  • Site collection admins, can access site permissions page and edit groups. We cannot grant Owners SCA though, hence a fix is needed for the owners to once again be able to edit groups – Orange Juice Jones Mar 12 at 8:04
0

Please perform the following troubleshooting

  1. Sign in the subsite "Site Permission" page (/_layouts/15/user.aspx) of as top-level site admin, and check subsite owner permissions

  2. Sign in the subsite "Site Permission" page (/_layouts/15/user.aspx) of as top-level site admin. Delete subsite owner's permissions, and then re-grant Full Control permission to subsite owner.

6
  • Is No.1 correct ? Do you mean 'Sign in the "top-level site..., and not subsite? Also, when you say 'as top-level site admin' - can this be site collection admin? – Orange Juice Jones Mar 12 at 9:03
  • Also, I don't believe the sub-site level group exists in the top-level, as could not find it. – Orange Juice Jones Mar 12 at 9:06
  • Hi, OrangeJuiceJones. Thanks for your reply. I mean, as site collection administrator to access subsite "site permissions" page. – EchoDu_MSFT Mar 12 at 9:18
  • After deleting owners permissions, the owner group was removed from user.aspx page. Then I re added the group with full control. The same problem that the users within the group cannot access this page. – Orange Juice Jones Mar 12 at 9:36
  • I have resolved by creating a new group in top-level (with no permissions), and adding that same group to sub-site with full control. – Orange Juice Jones Mar 12 at 14:50
0

I have resolved by creating a new group in top-level (with no permissions), and adding that same group to sub-site with full control

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.