1

I am deploying a solution to a client's SharePoint Server 2016 site.

Whenever I deploy, Visual Studio returns the following error.

enter image description here

Details in my Output window are as below;

 ------ Build started: Project: SGMS_Mug, Configuration: Debug Any CPU ------
    Successfully created package at: C:\Users\administrator\Documents\Visual Studio 2015\Projects\SGMS_Mug\SGMS_Mug\bin\Debug\app.publish\1.0.0.1\SGMS_Mug.app
    ------ Deploy started: Project: SGMS_Mug, Configuration: Debug Any CPU ------
    Active Deployment Configuration: Deploy SharePoint Add-in
    Skipping deployment step because a pre-deployment command is not specified.
    Skipping the uninstall step because the SharePoint Add-in is not installed on the server.
    Install SharePoint Add-in:
    Uploading the SharePoint Add-in...
    Installation is in progress (00:00:00)
    Add-in failed to install, cleaning up...
    Successfully uninstalled the SharePoint Add-in.
    Add-in installation encountered the following errors:
    3/8/2021 11:56:44 AM
    @"Error 1
    CorrelationId: 06dcc43c-e21b-40ae-a246-705611fdc1c1
    ErrorDetail: Apps are disabled on this site.
    ErrorType: Configuration
    ErrorTypeName: Configuration
    ExceptionMessage: Microsoft.SharePoint.SPException: Apps cannot be installed. Review the diagnostic logs for more details regarding app deployment failures.
    at Microsoft.SharePoint.Utilities.SPUtility.ThrowSPExceptionWithTraceTag(UInt32 tagId, ULSCat traceCategory, String resourceId, Object[] resourceArgs)
    at Microsoft.SharePoint.Packaging.SPUserCodeSolutionDeploymentGroup.Deploy()
    at Microsoft.SharePoint.Administration.SPAppTask.DeployOperation()
    at Microsoft.SharePoint.Lifecycle.MonitoredTaskExecution.DoTaskCore()
    Source: AppWeb
    SourceName: App Web Deployment
    Error occurred in deployment step 'Install SharePoint Add-in': Failed to install SharePoint Add-in. Please see the output window for details.
    ========== Build: 1 succeeded or up-to-date, 0 failed, 0 skipped ==========
    ========== Deploy: 0 succeeded, 1 failed, 0 skipped ==========

I checked and the Apps feature (Activate Apps that require accessible internet facing endpoints) under site settings for this particular site is Activated.

enter image description here

I have tried the following to resolve this issue;

  • Setup a new subscription service but it also gets stuck in the state of starting. I ran the New-SPSubscriptionSettingServiceApplication script in SharePoint 2016 Management Shell as an Admin to add and configure a new subscription service. enter image description here
  • During my troubleshooting I noticed there a number of ms-sql-s connections that are in time-wait state. I suspect these to be linked to the Subscription service.

Below is a list of SPServices and there states;

enter image description here

Kindly advise on how to resolve this.

4
  • Do you have the App Domain + App Catalog configured?
    – user6024
    Commented Mar 9, 2021 at 16:09
  • Yes the App Domain and Catalog are configured, however when I go to configure App URLs under App Management. I get a notification that Subscription Settings Service should be started for this to be configured.
    – Collin T
    Commented Mar 10, 2021 at 5:31
  • Did you create a Subscription service app and start the service instance?
    – user6024
    Commented Mar 10, 2021 at 15:32
  • Yes, the Subscription service app is created, however it doesn't start. It remains in the state of starting.
    – Collin T
    Commented Mar 12, 2021 at 8:55

1 Answer 1

1

Please check if SharePoint timer service and SharePoint Administration are running in all WFE servers.

Similar issue for your reference:

https://social.technet.microsoft.com/Forums/office/en-US/488d4d67-630b-4fdc-9051-bc7deeda4387/subscription-settings-service-application-status-starting-on-sharepoint-2016?forum=sharepointadmin

More information for configure an environment for apps for SharePoint Server:

https://chanakyajayabalan.wordpress.com/2013/12/10/sharepoint-hosted-app-2013-configuring-your-environment-for-app-deployment/

https://support.shortpoint.com/support/solutions/articles/1000272515-configure-the-subscription-settings-and-app-management-service-applications-sharepoint-2019-

5
  • Hello @Julie_MSFT, thanks for your help. We've made changes to the SharePoint timer service and Sharepoint Administration. The Sharepoint Foundation was not started but now its started, you can see that in the screenshots we've added to the edited question. However, the Subscription service is still stuck to starting. We've closely followed the guides you shared and they've helped give us a deeper insight into the issue we are dealing with. Could you kindly advise on why the service is still not starting
    – Gilboot
    Commented Mar 10, 2021 at 5:30
  • What did you mean "The Sharepoint Foundation now its started" however the Subscription service is still stuck to starting?Whether the Sharepoint Foundation equals to Microsoft SharePoint Foundation Subscription Settings Service?
    – Julie_MSFT
    Commented Mar 12, 2021 at 8:33
  • Hello @Julie_MSFT, just to clarify, the Microsoft SharePoint Foundation Subscription Settings Service status is "Provisioned" not yet "Online" as in the screen shoot added in edited question above. Subscriptions Settings Service Application under the Service Applications in Central Admin is still in a state of "Starting".
    – Collin T
    Commented Mar 12, 2021 at 9:05
  • Hello @Jule_MSFT, any advice for us?
    – Gilboot
    Commented Mar 14, 2021 at 8:03
  • Hi @Julie_MSFT, your advice was helpful, it gave us confidence in what we were doing. There was another issue we had to resolve but we are good now. Thanks again
    – Gilboot
    Commented Mar 19, 2021 at 6:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.