0

I have a Sharepoint 2016 Farm configured with Shared Roles. Below is the Configuration details.

  • 2 X Web Front End Servers with Distributed Cache
  • 2 X Application Servers with Search
  • 1 X Domain Controller
  • 2 X SQL Servers in Failver Cluster (configured with High Availability)

Although I am facing an issue wherein One of the Web Front End Server (WFE1) is sometimes not able to connect to database. I see the logs and find the below Error message.

"Unknown SQL Exception 53 occurred. Additional error information from SQL Server is included below. A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server)"

This issue happens twice in a day. How do I figure out what is happening wrong. Any support will be highly appreciated.

0

Please, check another Network itens like the Web Front-Ends load balance, Proxies etc. This behavior contains a root-cause without SharePoint association, if this root-cause is from SharePoint, other Servers had been impacted with same trouble.

2
  • All the other servers are running fine. Event the other Web Front End server (WFE-2) is having no trouble connecting to database. I do not understand what is happening wrong. That too this server also connects most of the time just that it fails twice a day for 30 mins. – Pankaj Dalvi Mar 1 at 4:45
  • @PankajDalvi, please, run SharePoint Wizard only in the server with database connection trouble. Pear attention if in the Wizard or Central Admin has differences between servers upgrades of SharePoint build. – Antonio Leonardo Mar 1 at 13:52
0

Below is a similar thread, take a reference to the checking list in this post:

Sharepoint Database Connection issue after recovering the content Database

Hope this may help.

2
  • I have tried all this. Still the issue is coming. Its not like the connection is not happening, its happening but its throwing an error only sometimes that too only on the First Web Front End Server. Other server is not logging any exceptions of this kind. – Pankaj Dalvi Mar 1 at 9:07
  • Please check with your Network Team or System Team about this Server has some issues to connect to SQL Server, Try to telnet from this server to SQL Server – user3520155 Mar 29 at 13:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.