0

I have installed a standalone Sharepoint Enterprise 2019 server and a Developer SQL 2019 server. I was able to open central administration, create a web application and a site collection. However, when I follow the site collection URL, I instantly get HTTP 404 or 400 errors.

I have tried everything I could think of: recreate the web application and site collection, change ports, use the IP address directly instead of the URL, check that the site is not locked, try to access it from a different computer (still 400 or 404 errors), restart IIS, check that all IIS sites and application pools are running...

Can I get some help here please?

Update: I have realized that the sites don't work only when I create URL names of the form "intranet.site.com", even though the DNS is set up. When I create site collections with the URL being the server name, everything works for some reason.

3 Answers 3

0

Are you accessing these sites from the server itself? If so, you’re running into loopback protection.

See https://docs.microsoft.com/en-us/troubleshoot/windows-server/networking/accessing-server-locally-with-fqdn-cname-alias-denied for details. Although it’s talking about Windows Server 2003, it still applies to more recent server versions.

1
  • I have tried to access it from the server itself, and another machine too. Again, domain url works, but normal url doesn't. Feb 12, 2021 at 21:29
0

Based on your description, I understand that you have configured alternate access mappings for the site collection in the central administration. And you add a new host name in DNS.

You should add IIS binding for the new host.

Go to IIS -> Select the web application from the "Connections" panel on the left under "Sites" node -> Click "Bindings" on the right -> Add -> Enter host name value.

Reference:

Configure Alternate Access Mapping In SharePoint Server

2
  • Hi. Thnks for your response. I have created a web app and a site collections with the URL of the form <servername>:<port>, and it works fine. But when I edit bindings in IIS and configure AAM in CA to switch to proper URL like portal.company.com, the site stops working, and I cannot even access it by using the IP address directly. Feb 11, 2021 at 11:14
  • I have tried to use the URL of the form portal.company.com.domain.local, and it also works. But I can't get to work the URL that I need: portal.company.com Feb 12, 2021 at 21:26
0

This might be a DNS related issue. Could you please check if nslookup portal.company.com gives you the desired IP-Address of your server? My following answers will rely on that.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.