We have dedicated WF Farm (3 WF Servers - WF1, WF2, WF3) for our SharePoint environment. The WF certificate was expired. So we have panned to update the WF certificate steps are followed by this reference URL. I have changed the server time as mention in the 1st step. then while proceeding 2nd step "Get-WFFarm" cmdlet threw an exception "The type initializer for "System.Data.SQLClient.SQLConnection Configuring system failed to initialize" only in WF1 server on other 2 servers (WF2 and WF3) this cmdlet was ran successfully without exception.

Can anyone help me this.

1 Answer 1


The problem was solved, the problem was with my powershell.exe.config file it has incorrect assembly binding. so i ran Get-WFFarm command in powershell ise with WFM Run-AS account. Then it was worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.