1

Using a SharePoint 2016 on-premise solution.

We have a List who's results do not appear in search...either the search bar on top of the list or the global search. All other content of the SharePoint site is available (or at least seems to be). I have tried re-index that particular list, in the list settings, but it still does not appear.

Any idea on how to get this list indexed and searchable ?

EDIT: Allow items from this list to appear in search results' settings is also enabled. Tried rebooting, blowing away the index and doing a full crawl. Results still don't appear.

I believe this list used to a message board or wiki ... is there something special I need to do with the column sources ?

EDIT: The answer seemed to be going into Central Administration, Upgrade and Migration, Enable Features on Existing Sites, checking "Enable all sites...", and Enterprise Search. We previously had "SharePoint Server Standard Features" which for some reason was insufficient.

11
  • Please, may you share the your Farm config: if this Farm installed using MinRole or Custom, and the Search Service Application (in this Farm) is configured properly? – Antonio Leonardo Feb 5 at 13:34
  • @AntonioLeonardo How can I check this ? Yes, I believe the search service application is fine because it is returning all other results. – bulltorious Feb 5 at 14:53
  • You check this information from SharePoint Central Admin, in menu group "Application Management" -> "Manage Service Applications" – Antonio Leonardo Feb 5 at 19:49
  • 1
    Does the list appear in the Crawl Log in the SSA? Have you mapped any of the list crawled properties to managed properties at the site level and recrawled? – Trevor Seward Feb 7 at 21:35
  • Depends the your Search Service Application Crawler Configuration: After the Search Service Application deployed, you need to create a Enterprise Search Site Collection in separate and dedicated Web Application; then, you can configure your Crawler (the first level of crawler configuration is by Site Collection). I indicate study Microsoft Docs, that contains all step-by-step leves to configure your Crawler, because without Crawler, you cannot resolve your problem – Antonio Leonardo Feb 7 at 21:41
1
+50

On Premises SharePoint Search can be a Beast! Thankfully my company has moved to SharePoint Online / O365 - which is its own basket of messiness.

My suggestions are nuclear options, and have worked for me when I have had similarly intractable issues with SharePoint Search.

Either solution should be performed on a weekend, preferably a long weekend if your SharePoint environment is large and/or if you are also indexing non-SharePoint content.

  1. First try the Atom Bomb: Reset The Entire Search Index and perform a new full crawl. I know this probably sounds crazy, but this has fixed a number of search issues I have encountered over the past decade or so.

  2. If above fails, use this option, the H-Bomb Option:

    a. If your Search Service indexes non-SharePoint content, be sure to sufficiently document those additional sources

    b. Delete all Search Service Application(s) & Search Database(s)

    c. Create a new Search Service Application, See Also: here and here

    d. Once configured, run a full index of all content sources.

4
  • Tried the atom bomb - that didn't work. It is only that list. – bulltorious Feb 5 at 11:36
  • I have noticed that if I go to "Indexed Columns" f that list it has 1/20 called "Content Type". That column does not exist in list and none of the lists where search is working has an index listed. – bulltorious Feb 5 at 12:45
  • @bulltorious: the reason for the absence of the “Content Type” column is because it is revealed (but already existed as a hidden column) when you set a list/library to permit management of the content types. – A.k.A. Fritz Feb 9 at 5:54
  • It started working and I have no idea why. I awarded the bounty here because I thought this post to be the most beneficial. – bulltorious Feb 11 at 13:59
1

Maybe you have disabled 'Allow items from this list to appear in search results' settings. This setting specifies whether this list should be visible in search results:

On the List Settings page, under General Settings, click Advanced settings.

In the Search section, under Allow items from this document library to appear in search results, select Yes to include all of the items in the list or library in the search result.

Reference:https://docs.microsoft.com/en-us/sharepoint/make-site-content-searchable#show-content-from-lists-or-libraries-in-search-results

BR

7
  • Yes, that setting is enabled. That is what is making this thing baffling. Thank you for taking the time to respond. – bulltorious Feb 4 at 14:22
  • Have you confirmed if the crawl was successful for this list items by checking the craw log in the central admin? You can search crawl log using URL view, please see this article – Matiur Rahman Feb 4 at 16:52
  • @MatiurRahman Yes - The url is appearing as having been successfully crawled, it just won't appear in any results. – bulltorious Feb 4 at 20:58
  • You may try using the Search Tool if you haven't already done so. Also, turn on verbose logging and see if anything logs when you search on this list – Matiur Rahman Feb 4 at 21:23
  • I tried the search tool it just returns no results. – bulltorious Feb 4 at 22:30
0

Based on all dialog above about this theme, please, follow the instructions bellow (at Microsoft Support Article):

1.Navigate to the site that contains the list or library that you want to change.

2.Locate and click the list or library you want to customize.

3.Click Site Actions, and then click Site Settings.

4.Under Site Administration, click Site Libraries and lists.

5.Click an item from the list, for example, Customize “Shared Documents.”

6.On the List Settings page, under General Settings, click Advanced settings.

7.In the Search section, under Allow items from this document library to appear in search results, select Yes to include all of the items in the list or library in search result or No to exclude all items from search results.

You need to be a Site Owner to make these configurations.

7
  • this is already set correctly. – bulltorious Feb 10 at 21:48
  • @bulltorious, and about list Threshold? The itens quantity of List that you want to craw is bigger than Threshold limit? – Antonio Leonardo Feb 11 at 0:59
  • it is under the threshold limit. IT STARTED WORKING and I have no idea why. – bulltorious Feb 11 at 13:58
  • Good news! If you have a feedback how why I started working, please, share with us. – Antonio Leonardo Feb 11 at 17:41
  • 1
    Owh Man, I'm so sorry for this phrase. I'm not fluent in English, and I use automatically translate. Let me expose the correct answer: "Good news! If you know what is did to Search Crawler works at this specific List, please, share with us." – Antonio Leonardo Feb 16 at 1:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.