1

I am using Windows Server 2012. When I open "prerequisiteinstaller", all the prerequisites are already installed / activated, but when I open Setup, an error notification appears. Can you help me? enter image description here enter image description here enter image description here enter image description here

7
  • Which version of .NET are enabled on the server? Jan 29, 2021 at 13:08
  • I have enabled .NET Framework feature version 3.5 and 4.5 Jan 30, 2021 at 5:26
  • Sorry for classic, silly and annoying question: have you restarted the machine before trying to install SharePoint? Jan 30, 2021 at 17:50
  • of course sir.. Jan 31, 2021 at 6:13
  • Did you run the pre-req installer as admin? Feb 2, 2021 at 0:38

1 Answer 1

0

First of all, check if the server has connected to Internet. After, please, (1)restart the server and (2)re-execute the prereq again and do the steps (1) and (2) until you change this status. If that doesn't work, go to the command line (Powershell) with Admin privileges and execute this cdmlets bellow:

Import-Module ServerManager

Add-WindowsFeature Net-Framework-Features,Web-Server,Web-WebServer,Web-Common-Http,Web-Static-Content,Web-Default-Doc,Web-Dir-Browsing,Web-Http-Errors,Web-App-Dev,Web-Asp-Net,Web-Net-Ext,Web-ISAPI-Ext,Web-ISAPI-Filter,Web-Health,Web-Http-Logging,Web-Log-Libraries,Web-Request-Monitor,Web-Http-Tracing,Web-Security,Web-Basic-Auth,Web-Windows-Auth,Web-Filtering,Web-Digest-Auth,Web-Performance,Web-Stat-Compression,Web-Dyn-Compression,Web-Mgmt-Tools,Web-Mgmt-Console,Web-Mgmt-Compat,Web-Metabase,Application-Server,AS-Web-Support,AS-TCP-Port-Sharing,AS-WAS-Support, AS-HTTP-Activation,AS-TCP-Activation,AS-Named-Pipes,AS-Net-Framework,WAS,WAS-Process-Model,WAS-NET-Environment,WAS-Config-APIs,Web-Lgcy-Scripting,Windows-Identity-Foundation,Server-Media-Foundation,Xps-Viewer –Source D:\sources\sxs

The last parameter "-Source" indicates the drive letter with the Windows Server 2012 media installation (USB or DVD); at least Windows Server 2012, to install new resources to Windows Server, requires the Media Installation.

2
  • It looks like I've done all of these steps before, but it's still not working. Monday, I'll try again and I'll let you know whether it worked or not. Thank you sir. Jan 30, 2021 at 5:34
  • @HanifMaliki, is it solution works? Feb 28, 2021 at 20:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.