0

I've set my libraries to require a check out to be able to edit a file. However when I check out a file, it opened in read only and I am unable to save the file. I have no column requirements and there's no other fields that required in the metadata. How can I get the file to not open in read only mode if I use the check out requirement?

Thank you for all your help in advance.

0

I want to confirm some information with you:

1.What’s your permission on this library? There are many possible reasons listed in this article, please compare your settings against it.

2.Does the issue only occur in the excel file? Try to open other office file (such as docx document )then check the result.

3.Change another library, set “Require check out”, then compare the result.

4.What will happen if you uncheck the “Require check out”, can you edit the file successfully without any issue?

Please feel free to post it back.

2
  • Hello, I have admin access as the site owner. It is with all files in the library. I thought maybe it was only excel but it's doing it to my PowerPoint and Word files as well. I can edit the files successfully without any issues but we're seeing that if one person opens the file and makes no changes to it and closes out. In the version history it shows that they've modified the file when they have not. – user94661 Jan 28 at 15:35
  • Is the problem that you open the file in read-only mode and unable to save it solved? I have attached the link to "article", please check it. Does that person check out and then check in the file? This behavior will lead to adding a version. – Li Zhang_MSFT Feb 3 at 11:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.