0

I have a Sharepoint Online sitecollection http://tenant.sharepoint.com/sites/test and I have set up an app to be able to get the authentication tokens in Azure AD (Sites.FullControl.All for Sharepoint).

I set up Postman to test the API calls and I'm getting expected results when I call https://tenant.sharepoint.com/sites/test/_api/web/lists/GetByTitle('Documents'), so the authorization is working (token is also not expired). As expected I can see "ItemCount": 1 among other information in the request.

However, when I want to list the items with https://tenant.sharepoint.com/sites/test/_api/web/lists/GetByTitle('Documents')/items I'm getting an empty array returned: "results": []. I then added app permissions to the sharepoint site with the following permissions (exactly this string):

<AppPermissionRequests>
    <AppPermissionRequest Scope="http://sharepoint/content/sitecollection" Right="FullControl" />
</AppPermissionRequests>

I have also tried it with /sitecollection/web/list as the scope and then choosing Documents in the next step, it didn't work either.

Unfortunately, I'm still getting an empty array. What could be the error here? Did I forget to set something up?

1
  • You can check whether the item has independent permissions. – Amos Jan 27 at 6:12
0

Can you try adding your permission like this.

<AppPermissionRequests AllowOnAppPolicy="true">
    <AppPermissionRequest Scope="http://sharepoint/content/sitecollection" Right="FullControl" />
</AppPermissionRequests>

AllowOnAppPolicy lets SharePoint check the permissions of the add-in instead of on user level. (More info)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.