We have the following:

2016 SharePoint OnPrem with 6 servers.

After installing KB4486753 to our SharePoint Servers, our search services throws the following error:

Sorry, something went wrong The base type 'Microsoft.Office.Server.Search.Internal.UI.SearchResultsLayoutPage' is not allowed for this page. The type Microsoft.Office.Server.Search.Internal.UI.SearchResultsLayoutPage, Microsoft.Office.Server.Search, Version=, Culture=neutral, PublicKeyToken=71e9bce111e9429c could not be found or it is not registered as safe.

This is preventing not only users from searching and accessing our directory, but I also cannot access the search services in central admin. I have been working with MS to resolve the issue but after 22 days of this issue, they have been less than helpful.

What I have done so far:

  1. restart services on all servers
  2. adjusted the web.config files to include the following code -
<SafeControl Assembly="Microsoft.Office.Server.WorkManagement.UI, Version=, Culture=neutral, PublicKeyToken=71e9bce111e9429c" Namespace="Microsoft.Office.Server.Search.Internal.UI" TypeName="*" Safe="True" />   

   <PageParserPath VirtualPath="/*" CompilationMode="Always" AllowServerSideScript="True" IncludeSubFolders="true" />
  1. Created a new DWORD called "LoaderOptimization" set to 1 in the HKEY_LOCAL_MACHINE\SOFTWARE\MIcrosoft.NetFramework area of the Registry Editor (with an IISREST)

Nothing has resolved the issue at all.

Has anyone experienced this and what was the resolution.

  • running the SharePoint configuration wizard might help to add missing entries to the web.config Feb 4, 2021 at 10:19

2 Answers 2


The assembly you added seems to be "Microsoft.Office.Server.WorkManagement.UI" not "Microsoft.Office.Server.Search.Internal.UI.SearchResultsLayoutPage" shown in the error message.

How about adding the following assembly name space to web.config instead?:

Hope it works!


This could also happen in SharePoint 2019 if you convert a server from a WFE to a custom one, and add search components. SharePoint doesn't notice that the dll is needed, so it doesn't get updated. You will need to manually add the reference in the Search's web.config.

Seems to simply be a bug.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.