0

I would like to Hide the option "People in Organisation with link can edit" and user should be able to send or share link with Specific user.

Right now i have special permission for that i have "grayed out" the option "People in Organisation with link can edit" and when it comes to sending link by selecting "specify user", it sends an approval to site owner which i do not want SharePoint to send the approval email. Though i need to send the user directly to another user.

Please let me know, if i have missed to select any permission in permission Levels.

Appreciate your support !

2

Solution first: You can use PowerShell to disable People in your organization sharing links in a site:

Set-SPOSite -Identity <SiteURL> -DisableCompanyWideSharingLinks 1

Note that you need to be a Global admin or SharePoint admin to run the command.

Turn “Allow access requestsoff via Settings > Site permissions > Change how members can share to avoid sending approval emails to Site Owners.


Explanation:

You are seeing this behavior because the site has limited sharing site while "Allow access requests" enabled under "Site sharing settings".

enter image description here

While using default permission levels, the "People in organization with the link" and "Specific people" options are both available without approval when user has at least Contribute permission in a library. Users who have Read permission (or less) will need approval from Admins to do the sharing.

Reference: Limit sharing in Microsoft 365.

4
  • Thank you for the script, i have couple of questions 1.does script disable to all permission levels (site admin, Owner, Mem) 2. How to remove permanently "Web-Only Limited access" from Site Permission
    – striker92
    Jan 20 at 7:21
  • @striker92 1. Yes, the script disables the link on a site level, for all user roles. 2. The “Web-Only Limited access" permission is a system permission managed by SharePoint and cannot be removed/deleted in a site. You can only remove this permission from a user by changing the permission inheritance or reset user permission on a higher level. Jan 21 at 1:05
  • Thank you for the explanation, it was really helpful.
    – striker92
    Jan 21 at 9:32
  • @striker92 Would you please give it a vote or accept it as answer if you find the reply helpful? It will help others in this forum to find answers quickly as well. Thanks. Jan 21 at 23:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.