1

We've got a blank people picker window after installation. Has anybody met this?enter image description here

enter image description here

enter image description here

1 Answer 1

0

As per the error, the PickerHierarchyControl.js is missing in your server. This file is located at the below path:

C:\Program Files\Common Files\microsoft shared\Web Server Extensions\15\TEMPLATE\LAYOUTS

So as a quick fixe,

  • Make sure that you have cleared the browser cache,
  • If the issue still exists, I would suggest copying the same file PickerHierarchyControl.js from another working farm/server and paste it into your farm on the same path!
6
  • Hello Mohamed. Thanks for your reply. A strange thing that I have this js file on the server. Even if I overwrite this file from working farm it isn't helpful. Commented Jan 19, 2021 at 11:57
  • Hi Andrey, Sad to hear that, please tell me How many servers you have on your farm? have you recently configured AAM? Commented Jan 19, 2021 at 12:02
  • We have this issue in the two different farms. 1st farm is single-server sp2016, 2nd is 2-server sp2019 farm. Both farms had been deployed with SpAutoInstaller. AAM is configured by default. Commented Jan 19, 2021 at 12:11
  • Looks like there is a specific security policy applied on your side that may block such files! Commented Jan 19, 2021 at 12:23
  • Yeah, could be. That is exactly what we are investigating right now.. =) Commented Jan 19, 2021 at 13:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.