0

Did anybody try applying localization using PNP Provisioning for SharePoint groups? I have tried but it is not working. Can somebody please help?

<?xml version="1.0"?>
<pnp:Provisioning xmlns:pnp="http://schemas.dev.office.com/PnP/2015/12/ProvisioningSchema">
    <pnp:Preferences Generator="OfficeDevPnP.Core, Version=2.0.1601.0, Culture=neutral, PublicKeyToken=null" />
    <pnp:Localizations>
        <pnp:Localization LCID="1034" Name="Spanish" ResourceFile="SiteColumns-fr-FR.resx"/>
        <pnp:Localization LCID="1033" Name="English" ResourceFile="SiteColumns-En-EN.resx"/>
    </pnp:Localizations>
    <pnp:Templates ID="CONTAINER-SharePointPalsDemo">
        <pnp:ProvisioningTemplate ID="SharePointPalsDemo" Version="1" xmlns:pnp="http://schemas.dev.office.com/PnP/2015/12/ProvisioningSchema">



            <pnp:SiteFields>


                <Field ID="{793F0419-9A72-48D9-B983-91BD359E5387}" Name="{resource:PNPFieldInternalName}" StaticName="MyCustomPNPField" DisplayName="{resource:PNPFieldDisplayName}" Type="Note" Required="FALSE" RichText="FALSE" Group="My Custom PNP Fields" />

            </pnp:SiteFields>

            <pnp:ContentTypes>

                <!-- Bookmark ContentTypes -->
                <pnp:ContentType ID="0x010500C562BA980E1C457B97298CA27EC2C843" Name="MyCustomContentType" Description="Test Description" Group="Custom Group">
                    <pnp:FieldRefs>
                        <pnp:FieldRef ID="793F0419-9A72-48D9-B983-91BD359E5387" Name="{resource:PNPFieldInternalName}" />
                    </pnp:FieldRefs>
                </pnp:ContentType>

            </pnp:ContentTypes>
            <pnp:Security>

                <pnp:SiteGroups>
                    <pnp:SiteGroup
                        Title="{resource:GroupName}"
                        Description="{resource:GroupName}"
                        Owner="{resource:Owner}"
                        OnlyAllowMembersViewMembership="false">
                        <pnp:Members>
                            <pnp:User Name="{resource:Owner}"></pnp:User>
                        </pnp:Members>

                    </pnp:SiteGroup>
                </pnp:SiteGroups>

                <pnp:Permissions>
                    <pnp:RoleAssignments>
                        <pnp:RoleAssignment Principal="{resource:GroupName}" RoleDefinition="Contribute">
                        </pnp:RoleAssignment>
                    </pnp:RoleAssignments>
                </pnp:Permissions>
            </pnp:Security>


        </pnp:ProvisioningTemplate>
    </pnp:Templates>
</pnp:Provisioning>```

1 Answer 1

0

I haven't tried recently but a couple of years ago the only way to make it work is if your Office 365 profile languages (Delve->About me->Update profile->How can I change language and regional settings?->here->ellipsis (...)->Language and Region->My Display Languages:) are empty. If you have a language selected then it will not populate the strings in the other languages. I don't know whether that is still the case.

1
  • I have already changed the language and it is working for Site Columns but is not working for SharePoint Groups
    – Jeevana
    Jan 15, 2021 at 17:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.