0

We migrated our SharePoint Site from SP 2010 to SP 2013. We have a designer workflow on a custom list and the workflow has couple of approval task forms. The issue we are facing is, workflow 'Failed on start' only for the first item added on day. Workflows works fine and assigns task forms as expected from the second item. I checked the ULS logs and I see these messages-

RunWorkflow: System.UnauthorizedAccessException: Access to the path 'C:\Users\accountname\AppData\Local\Temp\c1e6ac0b-c897-4e0c-bb6d-a6bae5c4f572\Xoml.c198ca3c_a20b_4eef_b7f0_de437f582651.16.3072.18.3072.dll' is denied The name of the dll changes with every day.

Workflow history show -

Workflow Cancelled === System Account ===Workflow XXX was canceled by System Account.
Error === System Account === XXX failed to start.

1
  • I assume you've republished the workflow using SPD 2013 in the new environment? – Warwick W Jan 13 at 22:56
0

A few things you can check:

  1. Open SharePoint Designer 2013 using an Administrator account, which is not System Account, then publish the workflow again.

  2. Clear the SharePoint Designer cache. Reference: How to Clear Your SharePoint Designer 2010/2013 Cache.

  3. Clear the SharePoint Designer login credentials as referred in this post: SharePoint designer 2013 workflow saving error.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.